Nextcloud 28.0.6 Files says "No Files In Here" and Nextcloud Macosx App will not sync for one ip address only

I run nextcloud docker on my localhost with mariadb. I am having trouble with accessing files with both the nextcloud app on macosx and on the web browser. I can log into my account but it just shows “no files in here.” My error logs do not show anything. Nextcloud shows my files on every other device and other ios devices. You can clearly see below that the data is there with 500gb being used.

Details:

Nextcloud version (eg, 29.0.5): 28.0.6
Operating system and version (eg, Ubuntu 29.04): Ubuntu 22.0.4
Apache or nginx version (eg, Apache 2.4.25): no apache or nginx
PHP version (eg, 8.3):

The issue you are facing:

No files error

Is this the first time you’ve seen this error? (Y/N): This is not first time. It resolved itself in the past but I cannot remember how I fixed it.

Steps to replicate it:

  1. Log in via 192.168.1.132
  2. No files in here
  3. Nextcloud macosx app not working on same device

The output of your Nextcloud log in Admin > Logging:

{"reqId":"h5C9y1277m2Ox1m2euQs","level":1,"time":"2024-06-10T03:19:38+00:00","remoteAddr":"192.168.1.132","user":"--","app":"no app in context","method":"GET","url":"/index.php/204","message":"IP address throttled because it reached the attempts limit in the last 30 minutes [action: login, delay: 200, ip: 192.168.1.132]","userAgent":"Mozilla/5.0 (Macintosh) mirall/3.13.0git (build 22490) (Nextcloud, osx-23.3.0 ClientArchitecture: arm64 OsArchitecture: arm64)","version":"28.0.6.1","data":[],"id":"666675dc3df0f"}

{"reqId":"YZ00DCquR2JRN4dvgotA","level":1,"time":"2024-06-10T03:19:38+00:00","remoteAddr":"192.168.1.132","user":"--","app":"no app in context","method":"GET","url":"/index.php/204","message":"IP address throttled because it reached the attempts limit in the last 30 minutes [action: login, delay: 200, ip: 192.168.1.132]","userAgent":"Mozilla/5.0 (Macintosh) mirall/3.13.0git (build 22490) (Nextcloud, osx-23.3.0 ClientArchitecture: arm64 OsArchitecture: arm64)","version":"28.0.6.1","data":[],"id":"666675fc146a3"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
  'upgrade.disable-web' => true,
  'instanceid' => ‘id’,
  'passwordsalt' => ‘salt’,
  'secret' => ‘secret',
  'trusted_domains' => 
  array (
    0 => '127.0.0.1:8080',
    1 => '192.168.1.236:8080',
  ),
  'datadirectory' => '/mnt/hdd1/data/',
  'dbtype' => 'mysql',
  'version' => '28.0.6.1',
  'overwrite.cli.url' => 'http://192.168.1.236:8080',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => ‘user’,
  'dbpassword' => ‘password’,
  'installed' => true,
  'log_type' => 'file',
  'logfile' => '/var/www/html/data/nextcloud.log',
  'loglevel' => 1,
  'logdataformat' => 'F d, Y H:i:s',
  'debug' => true,
  'maintenance' => false,
);

The output of your Apache/nginx/system log in /var/log/____:

Does not output anything

Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.

Your web server is not yet properly set up to allow file synchronization, because the WebDAV interface seems to be broken.
Last background job execution ran 4 months ago. Something seems wrong. Check the background job settings.
Accessing site insecurely via HTTP. You are strongly advised to set up your server to require HTTPS instead, as described in the security tips ↗. Without it some important web functionality like "copy to clipboard" or "service workers" will not work!
This instance is running in debug mode. Only enable this for local development and not in production environments.
Server has no maintenance window start time configured. This means resource intensive daily background jobs will also be executed during your main usage time. We recommend to set it to a time of low usage, so users are less impacted by the load caused from these heavy tasks. For more details see the documentation ↗.
Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation ↗.
Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation ↗.
The database is used for transactional file locking. To enhance performance, please configure memcache, if available. For more details see the documentation ↗.
Your installation has no default phone region set. This is required to validate phone numbers in the profile settings without a country code. To allow numbers without a country code, please add "default_phone_region" with the respective ISO 3166-1 code of the region to your config file. For more details see the documentation ↗.

Tried:

  1. sudo docker exec -it nextcloud-app-1 php occ security:bruteforce:reset 192.168.1.132
  2. Removing browser history and cache
  3. Changing local ip address of macbook
  4. Changing file settings according to other posts

I am receiving this error in the console. I have tried safari, firefox, chrome, and brave browser and they all say the same thing.

Turns out simply changing the port for 8080 to 8081 allowed me to view my files again. Nowhere in the logs did it lead me to this answer. I just performed trial and error for 6 hours…

The most worrying is the broken webdav interface. Not sure how the whole docker is set up, if you go through a reverse proxy or something, where stuff could be changed/filtered. I added docker to the tags, so perhaps with more knowledge can help you soon.

That is a bit strange and difficult to see from the data you provided. Perhaps other services running at this port as well? Or some firewall/security thing?
If you are using it locally, you could even use a dedicated IP address for this and run this on default ports.
On the long term, especially if you want to use it from outside, you should switch to https.