Nextcloud 25.0.6 - Time not correct in activity mail sent by nextcloud

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.6
Operating system and version (eg, Ubuntu 20.04): debian 11 Bulleye 5.10.179-1
Apache or nginx version (eg, Apache 2.4.25): apache 2.5.56
PHP version (eg, 7.4): 8.1.18

The issue you are facing:

Hello everyone,
I have a bug with the time of the activities sent by mail.
I already report this bugon the github but when I have open the issue my nextcloud isn’t up to date so my issue Has been close #36410 / #38442 .
Today I have update my nextcloud instance from 24.0.7 to 24.0.12 to 25.0.6 and the bug is still here.
I also upgrade my php-fpm and modules from 8.0 to 8.1 .
Since execution time of last cron isn’t displayed in interface like nextcloud 24.X, the bug now impact only the time in activities mails.
There is 2 hour (minus “-2”) difference with the real time in my country (France).
I have configured the time zone in the nextcloud settings… (Europe/Paris)
The time is correct in the activities section (see attached pic).


Is this the first time you’ve seen this error? (Y/N): N (I encourtered this « bug » in nextcloud v24.0.7 and v27.0.12)

Steps to replicate it:

  1. Read activities mail sent by nextcloud (verify receive date and time indicated for the activity) compare it with the time indicate in actvity sections in nextcloud web client

The output of your Nextcloud log in Admin > Logging:

Logs too long

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

{
    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "overwrite.cli.url": "https:\/\/***REMOVED SENSITIVE VALUE***\/",
        "htaccess.RewriteBase": "\/",
        "trusted_domains": [
            "***REMOVED SENSITIVE VALUE***",
            "***REMOVED SENSITIVE VALUE***"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "25.0.6.1",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "installed": true,
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "smtp",
        "mail_sendmailmode": "smtp",
        "mail_domain": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpsecure": "tls",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": 1,
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpport": "587",
        "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
        "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
        "templatedirectory": "",
        "skeletondirectory": "",
        "trashbin_retention_obligation": "7, 8",
        "defaultapp": "files",
        "logtimezone": "Europe\/Paris",
        "default_language": "fr",
        "default_locale": "fr_FR",
        "default_phone_region": "FR",
        "activity_expire_days": "30",
        "allow_user_to_change_display_name": false,
        "lost_password_link": "disabled",
        "oidc_login_provider_url": "***REMOVED SENSITIVE VALUE***",
        "oidc_login_client_id": "***REMOVED SENSITIVE VALUE***",
        "oidc_login_client_secret": "***REMOVED SENSITIVE VALUE***",
        "oidc_login_auto_redirect": false,
        "oidc_login_logout_url": "https:\/\/***REMOVED SENSITIVE VALUE***\/",
        "oidc_login_end_session_redirect": false,
        "oidc_login_button_text": "Connexion avec M365 (***REMOVED SENSITIVE VALUE***)",
        "oidc_login_hide_password_form": true,
        "oidc_login_use_id_token": false,
        "oidc_login_attributes": {
            "name": "name",
            "mail": "email",
            "id": "email"
        },
        "oidc_login_default_group": "utilisateurs-openid",
        "oidc_login_use_external_storage": false,
        "oidc_login_scope": "openid profile",
        "oidc_login_proxy_ldap": false,
        "oidc_login_disable_registration": false,
        "oidc_login_redir_fallback": false,
        "oidc_login_tls_verify": true,
        "oidc_create_groups": false,
        "oidc_login_webdav_enabled": false,
        "oidc_login_password_authentication": false,
        "oidc_login_public_key_caching_time": 86400,
        "oidc_login_min_time_between_jwks_requests": 10,
        "oidc_login_well_known_caching_time": 86400,
        "oidc_login_update_avatar": false,
        "maintenance": false,
        "theme": "",
        "loglevel": 1,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379
        },
        "simpleSignUpLink.shown": false,
        "updater.secret": "***REMOVED SENSITIVE VALUE***"
    }
}