Nextcloud 22, Apache 2, php8.0-fpm aktivieren

Hallo alle zusammen.

Ich habe mein Nextcloud 22, mit Apache2 auf einem Heimserver am laufen.
Ich nutze Ubuntu 20.04.3 LTS und php 8.0.13

Das ganze l├Ąuft recht zuverl├Ąssig.
Ich w├╝rde gerne das php Modul fpm aktivieren, weil ich mir da eine bessere Performance von verspreche. Jedenfall lese ich das ├╝berall.

Allerdings will ich mich vorher ein wenig absichern, ob ich alles richtig mache.

Ich w├╝rde folgende machen (das fpm Modul ist bereits installiert):

Dann in der /etc/php/8.0/fpm/pool.d/www.conf folgendes einf├╝gen:

pm = dynamic
pm.max_children = 120
pm.start_servers = 12
pm.min_spare_servers = 6
pm.max_spare_servers = 18

In der /etc/php/8.0/apache2/php.ini folgendes einf├╝gen bzw ├Ąndern:

opcache.enable=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1

Anschlie├čend:

a2enmod proxy_fcgi setenvif
a2enconf php8.0-fpm

Und zum Schlu├č

service apache2 restart && service php8.0-fpm restart

Jetzt meine Frage:
Ist der Ablauf so Ok?
Und wenn nicht, wie schaffe ich es php-fpm wieder zu deaktivieren, damit die alte Konfig wieder l├Ąuft?

Danke f├╝r eure Hilfe.

Gru├č Helix

Hat sich erledigt.
Hab mich rangetraut und es hinbekommen.