Nextcloud 20.0.2snap2 Interface Incredibly Slow

Also the same

Ubuntu server 20.04 + Nextcloud 20.0.2 snap 2 running as a snap
Disabled Collabora + CODE now I have the normal performance as before

1 Like

Same! 20.04 + Nextcloud 20.0.2 snap 2

I’ve opened an issue in Nextcloud/richdocuments (nextcloud/richdocuments#1282).

At least for now we have the solution: disable collabora and the code server either via the web-interface admin settings (if you can get there), or via the server terminal (sudo snap run nextcloud.occ app:disable richdocuments && sudo snap run nextcloud.occ app:disable richdocumentscore).

3 Likes

Confirmed sudo snap run nextcloud.occ app:disable richdocuments && sudo snap run nextcloud.occ app:disable richdocumentscore resolved my issues.

Just like everyone else the issue began happening after the latest update.

1 Like

Yes, confirming that this fixed my issue as well.

1 Like

Guys… I was freaking out, when I realized how slow my webinterface was. Thought of the worst like got hacked or so. You are brilliant. I can confirm the same behaviour since the update and the fix works perfectly! Thanks, highly appreciated!

1 Like

I hope that everybody agrees that this solution does not fix the problem.
I use Office online editing in Nextcloud and now I had to disable this function because of the problem. That is why I need this function working back ASAP.

What I found is that if you go to Settings for CODE server, there is a link to Collabora Online, but it’s without /index.php - this is the right link, /index.php/settings/admin/richdocuments , I get /settings/admin/richdocuments . Maybe this can help?

@aob01 can you please exactly explain what you did?
Because I am not able to edit settings of Collabora server as you mentioned.
I will be glad for step by step tutorial.
Thank you.

It’s just my observation what probably went wrong.

Problem is that I am not able to edit settings for Collabora Online server that is as default.
So It is impossible for me to change it.

Thanks a lot!!!

I am having this exact same issue with 20.0.2snap2 and I also was preparing for the worst, but disable Collabora Online ‘fixes’ it. I can keep the built-in CODE server enabled, it would seem.

I hope it gets fixed soon, because I’m also using Collabora.

Edit:
If I leave both enabled (and everything is slow as…), when I go to Settings > Colloabora Online, it also shows an error there: ‘Kon niet verbinden met de Collabora Online server.’ or in English: ‘Cannot connect to the Collabora Online server’.
Even though I have a local CODE server installed and selected in the options. So, it seems Collabora is trying to connect to some online server somewhere, or perhaps tries to connect to my own locally installed server but fails?

No, what you mean is that, on the Settings > CODE Server, there is a message saying the settings are not really there, but the settings are at Settings > Collabora Online.
To help you get there, it includes a link to the correct settings page.
However, that link is no longer correct. That is annoying of course and should be fixed, but it’s just that: a link to another page with settings to make it more convenient for you. That wrong link cannot be related to the issues we’re experiencing, in my opinion.

Just wanted to thank everyone for bringing this up - I just recovered from an unrelated issue that took me down 100% for a few days and then ran into this and was running out of hope…

For the record, disabling the Collabora app (CODE is still enabled for me) immediately resolved the slow response times. Running the snap package on a Debian VM in Proxmox. Can’t wait to hear more as this gets figured out!

Certainly not, but we’ve determined that this has nothing to do with the snap itself (it effects other types of installs as well). Something needs to be fixed in richdocuments/richdocumentscode. Please follow this issue, it’s all the rest of us are doing as well.

3 Likes

same here - disabling Collabora & CODE server helps.

(btw.: I’m running debian 10 “buster” (Linux 4.19.0-13-amd64 x86_64) and ONLYOFFICE 6.2.0 within nextcloud snap version 20.0.2
ONLYOFFICE works!)

I also had this issue and understood that this was an issue that had been fixed in a prior release and had come back and that would be fixed in the next release. I basically did a:

sudo snap refresh nextcloud --channel=latest/edge

followed by a:

sudo snap switch nextcloud --channel=stable

That gave me the latest edge release but will synchronies with the next stable release when available. Fixed it for me.

I am currently (therefore) running master-2020-11-28

If you don’t switch back to the stable channel, then you will get daily updates.

This is of course some risk in doing this as these are beta releases.

Thanks all for this thread.

I wasn’t even able to log in since two-factor would time out before the server could respond. Fixed for me per the github issue page.

I don’t think that will work out the way you hope. The edge channel reflects the current state of master, which is far ahead of the current v20 release in stable. The next release that goes to stable will also be a v20 release, and master will probably still be far ahead (thus making the refresh to stable technically a downgrade, which Nextcloud doesn’t support).

If you want to try this type of thing, I suggest using 20/edge instead which is a daily build of stable20, which does represent what’s coming in a v20 update. It’s still possible to end up stuck there, but it’s better. Note that I generally don’t recommend running any edge channels in production.

And another one confirming disabling the Collabora Online - Built-in CODE Server and Collabora Online App and the brings back a speedy nextcloud instance, which is a shame because I love the office integration in nextcloud, it’s a nice feature but until now with regular failures.

1 Like