Nextcloud 19.0.2: Activity view broken after installing KeeWeb

Hi,

I just installed KeeWeb from the “App Store” and now when opening the activity tab inside Nextcloud, it is not loaded but the “circling”-icon is shown.

The logs says:

[no app in context] Error: Exception: substr() expects parameter 3 to be int, bool given at <>

  1. /var/www/nextcloud/lib/private/AppFramework/App.php line 137
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Activity\Controller\APIv2 {}, “getFilter”)
  2. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“APIv2Controller”, “getFilter”, OC\AppFramework\ … {}, {filter: “self”, … "})
  3. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({filter: “self”, … "})
  4. /var/www/nextcloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ … {}, {filter: “self”, … "})
  5. /var/www/nextcloud/ocs/v1.php line 88
    OC\Route\Router->match("/ocsapp/apps/ac … f")
  6. /var/www/nextcloud/ocs/v2.php line 24
    require_once("/var/www/nextcloud/ocs/v1.php")

GET /ocs/v2.php/apps/activity/api/v2/activity/self?format=json&previews=true&since=0
from xxx.xx.xx.20 by user at 2020-09-02T13:25:19+00:00

As you can see on the intro page on the app store, Nextcloud 19 isn’t yet been supported by the KeeWeb app.

Due to the fact that you’ve already created an issue ticket in the related repository, I don’t understand why you’ve additonally created this request in the forum. This problem can only be fixed by the app developer.

Thanks. I thought it might be helpful to also have it posted here but in this case, the thread can be close / deleted.

Cheers