Nextcloud 18.0.9 stops working after Disk full error (CAN_INSTALL)

Nextcloud version: 18.0.9
Operating system: Ubuntu 18.04.5 LTS

I probably ran out of disk space and after trying to update my installed apps, which failed, Nextcloud is showing me a message that it needs to be installed (mentioning the CAN_INSTALL file). Same on the CLI:

$ sudo -u www-data ./occ status
Nextcloud is not installed - only a limited number of commands are available
  - installed: false
  - version:
  - versionstring: 18.0.9
  - edition:

Is this the first time you’ve seen this error?: Yes

Steps to replicate it:

I don’t know. Use my version of Ubuntu and then run out of disk space? :smiley:

The output of your Nextcloud log in Admin > Logging:
not accessible

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc800a5qxe1c',

The output of your Apache error log:

[Thu Nov 12 17:29:03.985304 2020] [access_compat:error] [pid 3231] [client] AH01797: client denied r configuration: /var/www/nextcloud/public/config
[Fri Nov 13 13:27:12.849529 2020] [access_compat:error] [pid 13122] [client] AH01797: client denieder configuration: /var/www/nextcloud/public/config

Your config file is a bit short. You are sure this is your actual config-file? Can you still login on your webinterface?

Your config file is a bit short.

Yeah that’s what I thought, too. I don’t know the internals of Nextcloud but maybe it got overwritten while some mechanism failed because of no free disk space? Just a guess.

I used this instance of Nextcloud for several years now so there should be more config :sweat_smile:

btw the database looks good to me, at least I could extract some data which I need right now. So maybe everything works again if I would have my old config? (which is not gonna happen because I don’t have a backup of it… lesson learned. At least the data seems to be still there)

I can not login. This is what the web interface looks like for me:

Well, the backup would be the easiest and best way. Have you used the updater app in the past? Then it might have a backup in your data folder:

omg THANK YOU :smiley: There was a backup in that location, I used the config.php from there and now everything is back to normal (at least it’s usable again). What a life saver :smiley: thank you so much!

ugh - I have the exact same error… an overnight sync flooded my server. I cleared my diskspace, but now my config.php is borked just like OP’s.

I have a backup of all my data - a backup of my database, but apparently not of my config. Is this fixable or am I just sol without the config.php?

also not sure if I should be creating my own topic here, since it’s exactly the same error as stated above. Only difference is that I’m running the latest build and on Opensuse.
Not using the webupdater so no luck finding the config.php file there…