Nextcloud 18.0.3 - UTF8mb4 appears not to be working

Hi,

I am losing the will to live with this.

Nextcloud version 18.0.3:
Operating system and version Debian Stretch 9.9:
Apache 2.4.25_:
PHP PHP 7.2.19:

The issue I’m facing:

Wherever I try to paste say :cake: (file section, Talk) I end up getting ??? instead.

Database is Barracuda since day one.

I followed the guides to enable UTF8mb4 obviously and conf has

[mysqld]
innodb_large_prefix=true
innodb_file_format=barracuda
innodb_file_per_table=1

Character and collation is utf8mb4
utf8mb4 is set to true
I ran the repair at the end

Security & setup warnings in admin overview - “All checks passed”

Symbols like :sunny: work fine.

What am I missing please?