Nextcloud 17 Web hosting issue - File not found

Hello,

i want to host my Nextcloud platform on a web hosting platform but i get the following error :

Fatal error: require_once(): Failed opening required ‘support/appinfo/app.php’ (include_path=’.:/home/homnet882’) in /home/homnet882/ownc/lib/private/legacy/app.php on line 260

I have made some research and i think i have to modify the include_path variable but i don’t know where.

thanks for your support

The mentioned file is usually part of the Nextcloud support app and is delivered with the standard Nextcloud package. Make sure that the file /home/homnet882/ownc/support/appinfo/app.php exists on your server. If not, download the Nextcloud rchive and extract the missing file.

1 Like

Thanks j-ed,

with your help i have resolv the issue. But now when i try to login i get another error

Server cannot execute your request. Technical informations : XfQSTrsiPWkA0KX1UfUN8wAAAE0

Below the associated log entry

{“reqId”:“XfQSTrsiPWkA0KX1UfUN8wAAAE0”,“level”:3,“time”:“2019-12-13T22:35:58+00:00”,“remoteAddr”:“154.72.150.12”,“user”:“rudy”,“app”:“index”,“method”:“GET”,“url”:"/index.php/apps/files/",“message”:{“Exception”:“OCP\Files\NotFoundException”,“Message”:"",“Code”:0,“Trace”:[{“file”:"/home/homnet882/ownc/apps/files/lib/Controller/ViewController.php",“line”:130,“function”:“getStorageInfo”,“class”:“OC_Helper”,“type”:"::",“args”:["/",false]},{“file”:"/home/homnet882/ownc/apps/files/lib/Controller/ViewController.php",“line”:178,“function”:“getStorageInfo”,“class”:“OCA\Files\Controller\ViewController”,“type”:"->",“args”:[]},{“file”:"/home/homnet882/ownc/lib/private/AppFramework/Http/Dispatcher.php",“line”:170,“function”:“index”,“class”:“OCA\Files\Controller\ViewController”,“type”:"->",“args”:["","",null,false]},{“file”:"/home/homnet882/ownc/lib/private/AppFramework/Http/Dispatcher.php",“line”:99,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Files\Controller\ViewController”},“index”]},{“file”:"/home/homnet882/ownc/lib/private/AppFramework/App.php",“line”:126,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:"->",“args”:[{“class”:“OCA\Files\Controller\ViewController”},“index”]},{“file”:"/home/homnet882/ownc/lib/private/AppFramework/Routing/RouteActionHandler.php",“line”:47,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:"::",“args”:[“OCA\Files\Controller\ViewController”,“index”,{“class”:“OC\AppFramework\DependencyInjection\DIContainer”},{"_route":“files.view.index”}]},{“function”:"__invoke",“class”:“OC\AppFramework\Routing\RouteActionHandler”,“type”:"->",“args”:[{"_route":“files.view.index”}]},{“file”:"/home/homnet882/ownc/lib/private/Route/Router.php",“line”:297,“function”:“call_user_func”,“args”:[{“class”:“OC\AppFramework\Routing\RouteActionHandler”},{"_route":“files.view.index”}]},{“file”:"/home/homnet882/ownc/lib/base.php",“line”:1000,“function”:“match”,“class”:“OC\Route\Router”,“type”:"->",“args”:["/apps/files/"]},{“file”:"/home/homnet882/ownc/index.php",“line”:42,“function”:“handleRequest”,“class”:“OC”,“type”:"::",“args”:[]}],“File”:"/home/homnet882/ownc/lib/private/legacy/helper.php",“Line”:488,“CustomMessage”:"–"},“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0”,“version”:“17.0.1.1”}

i answer to me.

Enable allow_url_fopen=on in php.ini