Nextcloud 16.0.3 on ReadyNAS 102 very slow transfer

Nextcloud version (eg, 12.0.2): 16.0.3
Operating system and version (eg, Ubuntu 17.04): Debian (Netgear ReadyNAS) and Client on W10
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1): 7.2.21

The issue you are facing:

I just did a clean installation of Nextcloud in my readynas 102. but trying to put files into it is extremely slow. after whole night it was only 2 GB transferred. it would take me a month to finish the sync. Now I’ve been trying different methods to transfer: with the sync software for win10 (2.5.3), with WebDAV by adding a drive in win10, or via browser on the nextcloud web service. in all of 3 the transfers are very very slow, in the range of kbps. In the sync software I can see often reports of “connection closed”

I browse remotely on the NAS file system and there I can see the nextcloud folders. I tried migrating my files there and it was at normal speed. roughly 900 Mbps, so it took just few hours to copy all the data. However it doesn’t show up on the Nextcloud browser and when running Sync is like uploading every single file again.

Is there any way to fix the transfer speed of the sync software, the WebDAV connection or the browser?

is there another way to migrate the files?

how can I make Nextcloud recognize he files copied by the browser directly in the files system?

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. clean instalation
  2. try to sync

Using the search function of this forum, which you find in the upper right corner, should provide the answer on the question, because it is asked on a regular base :wink:
Use the occ command line tool to update the Nextcloud database, like e.g.

 > ./occ files:scan <user-id>

  rescan filesystem

  files:scan [options] [--] [<user_id>...]

  user_id                will rescan all files of the given user(s)

      --output[=OUTPUT]  Output format (plain, json or json_pretty, default is plain) [default: "plain"]
  -p, --path=PATH        limit rescan to this path, eg. --path="/alice/files/Music", the user_id is determined by the path and the user_id parameter and --all are ignored
      --all              will rescan all files of all known users
      --unscanned        only scan files which are marked as not fully scanned
      --shallow          do not scan folders recursively
      --home-only        only scan the home storage, ignoring any mounted external storage or share
  -h, --help             Display this help message
  -q, --quiet            Do not output any message
  -V, --version          Display this application version
      --ansi             Force ANSI output
      --no-ansi          Disable ANSI output
  -n, --no-interaction   Do not ask any interactive question
      --no-warnings      Skip global warnings, show command output only
  -v|vv|vvv, --verbose   Increase the verbosity of messages: 1 for normal output, 2 for more verbose output and 3 for debug

So yes, that just is a workaround for the problem with the speeds. Having nextcloud with that terrible speed, I’d start asking whether you’re running the sync on local network?

Is there a firewall in between, which dav version are you running on your client and do you encrypt files on nextcloud?

And you can also let me know what speeds you have when you use the Web browser

Thanks, that is an answer for one of the questions. stil it doesn’t solve the problem of the slow transfer speed. that was what I searched in the forum initially :relaxed:

Regarding the database update, if someone else finds this later: I connected to the NAS via putty with root user and navigated to /apps/nextcloud/web and executed sudo -u admin ./occ files:scan username

It’s taking a while but I will update once it finishes and is tested.

HI, thanks for the help:

im running it in the local network. Nextcloud is installed in the NAS and the client is a win10 laptop.
There is a router in between (ASUS AC3200) but no firewall as far as I know.
No encryption.
Not sure how to check the dav version. I just followed the netflix documentation about how to setup the dav drive mapping on win10.
speeds are below 1Mbps, ad it kind of stops and restarts often. so is no a constant communication.

That’s a pity…

So what I can recommend is to try a different device, let’s say you use solid Explorer on your android device and add the dav device on it, and see if you get same results. A different Windows PC will also work.

This will rule out the client being the problem, if it shows to be slow everywhere else as well. :slight_smile:

1 Like

yeah. I will try it in another laptop later today. also need to wait that it finishes the database update :wink:

well the database update was the workaround solution. but speeds are very slow in the normal way.

I tried from another laptop. also win10. same thing. it took 10 minutes to upload an 8MB file