NextCloud 15: desktop client version 2.3.3.1 works, meanwhile 2.5.x doesn't work


#1

Now we are running nextcloud 15.0.2 and login users via SAMLv2 with a universities federation services that redirect our login queries.

The web client and the android client work correctly. But desktop client Windows and linux only work with client version 2.3.3.1, meanwhile 2.5.x don’t work. It get stuck on the grant acces page.


Connection Wizard is looping between "Log in" and "Grant access"
#2

Hello, I have the exactly same Problem. Are there any ideas what could be the reason for this? No errors are entered in the server log.


#3

If you use a Debian based linux you can do a

dpkg --list | grep libqt5keychain

There should be a

libqt5keychain0=0.5.0-1build1~gcc5.1

If not do a

sudo apt-get install libqt5keychain0=0.5.0-1build1~gcc5.1