Nextcloud 13 fresh install

I tried to do an upgrade to 13 from 12. I still have it in the vm but it ended up doing the same thing i am getting ina fresh install.

Here is the first issue:
Exception: The requested uri(/data/.ocdata) cannot be processed by the script ‘/nextcloud/index.php’)
/var/www/html/nextcloud/lib/base.php - line 950: OC\AppFramework\Http\Request->getRawPathInfo()
/var/www/html/nextcloud/index.php - line 37: OC handleRequest()
/data/.ocdata is there. I can not always upload files. Importing my new contacts back in. Throws this error everytime.

Here is my second issue:
Cannot modify header information - headers already sent by (output started at /var/www/html/nextcloud/apps/passman/personal.php:1) at /var/www/html/nextcloud/lib/private/AppFramework/Http/Output.php#69
This happens every 30 seconds.

Then this error only shows up once in a blue moon:
Following symlinks is not allowed (’/var/www/html/nextcloud/data/riggs498/files_external/uploads’ -> ‘/mnt/riggs498/’ not inside ‘/var/www/html/nextcloud/data/’)
It is there and owned by webserver. Does not always throw this error.

Did you ensure the permissions are set correctly? Those look like permission errors. Make sure it is not only owned by the www user, but also the proper rwx permissions are set. And I don’t know too much about the last one, but is the data dir correct in you config.php file?

Yes all the creditals are correct.

I get the exact same error when trying to adjust the maximum upload file size with the web ui… I never was able to figure what permissions to set to what files and directories for nextcloud. Is there any reference for this? I think the online manuals do not mention that.

Ok so I checked all my permissions are right and it seems to all work just fine, but I still get this error message in the logs (nothing else related otherwise) and I am unable to adjust the max-upload-size using the web gui. I get your error message in the logs when I try to do so.

I get exact the same error as riggs498 (first part). However, Nexcloud seems to work fine. Could you solve the issue? Sorry, I’m a total newby in setting up applications on servers and I couldn’t find a solution for my problem on “Google” either. Which permission should which folder (or user?) have? Do I have to change the “rwx” of the var/www/nextcloud?

Thanks for your help:)

BTW: The error notification does only appear when logging-in with the admin user.