Nextcloud 13, Debian 9 , and trying to test Collabora ... failed

Hello,
i’m trying to test Collabora (home use) with my fresh install of Nextcloud 13 (i follow admin manual 13) … but always the same error with collabora : (all the components are installed on the same server)

Internal Server Error
The server is unable to execute your request.
If this happens again, please send the technical details below to the server administrator.
The server log file can provide more information.
Technical information

Remote address: 10.10.10.15 (this my client workstation for testing )
ID of the request: ClI0Te1oWIaZr1LkJibH

Docker, Nextcloud (apache2 ) and docker are on the same server.

Thank you for helping me … (i follow Nextcloud offical tutorial)

When i launch docker it’s ok
docker run -t -d -p 127.0.0.1:9980:9980 -e ‘domain=office\.lag-dirty\.com’ --restart always --cap-add MKNOD collabora/code
if i try to to do this
docker run -t -d -p 0.0.0.0:9980:9980 -e ‘domain=office\.lag-dirty\.com’ --restart always --cap-add MKNOD collabora/code (0.0.0.0 allow me to point my webbrowser on the server , and it’s answer me : OK)

Do as it says and ask your admin for webserver logfiles. Like this nobody can tell you if it is a permission/resource/whatever problem.

Hello guys!!

I have the same problem on my “personal production” cloud!! Look at this:

Error interno del servidor
El servidor no pudo completar tu solicitud.

Si esto vuelve a suceder, por favor envia los detalles tecnicos siguientes al adminsitrador del sistema.

Puedes consultar más detalles en la bitácora del servidor.

Detalles técnicos
Dirección Remota: xxx.xxx.xxx.xxx
ID de solicitud: 8tCvNU3q45cfiUq8bw8s

What can I do?..

I’m the SysAdmin!!

LOL

Okay. Check the /var/log/apache2/error.log
Just please don’t drop the entire thing here. Use pastebin or something.

okay!! thanks!!

You’re so nice!!

the only thing i can see when i click on .odt file is , for access log
10.X.X.131 - - [27/Feb/2018:21:43:24 +0100] “GET /homecloud/index.php/apps/richdocuments/index?fileId=134433&requesttoken=eNoHGJuVWLjij4sSZop42JgiestxacoeHA0mzTUTGXY%3D%3AFrZxTMnhAoCM1dFIP%2BQrkMlENaRGGb1bKXdO%2FXliWh4%3D HTTP/1.1” 200 4413 “-” “Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0”

And for error

[Tue Feb 27 21:53:35.756014 2018] [authz_core:error] [pid 14171] [client 10.X.X.131:36096] AH01630: client denied by server configuration: /var/www/html/nextcloud/data/.ocdata

nextcloud and collabora are on the same server maison.domain-france.fr

And nextcloud Collabora setting is
https://maison.domain-france.fr:443

Docker run command
docker run -t -d -p 127.0.0.1:9980:9980 -e ‘domain=maison\.domain-france\.fr’ --restart always --cap-add MKNOD collabora/code
(double \ but your editor do not allow that !)

ok, … i’m going to forget collobara online

Eventually I had to do the same :frowning:

??


or