Nextcloud 13.0.5 and 12.0.10 secure and stabilize your server

Now it looks good.

THX!

But what did we learn of this issue: Never do an upgrade on a production server before checking it on a test instance.

That’s what I did. Upgraded a pure test instance, all fine. Then upgraded a private instance with no other users, all fine. WhenI finally upgraded my production instance, I got that SSL error. Two hours later all was fine, again.

Straightforward update using the WUI. Great work!

Hope so
:wink:

That folder has www-data as owner and 0770 as permissions.
I did the copy manually (as root) but itr did not help.

What to do?

df -h
 
?

I would suggest re-checking the ownership on all the NextCloud folders in your installation. I ran into a similar issue during an initial install and it turned out to be that a couple of files had “root:root” as owner, since I had copied things as root. NextCloud seems to be sensitive to having everything owned by “www-data:www-data” (or “apache:apache”, as the case may be).

I would do a “chown -R www-data:www-data *” from the top of the NextCloud hierarchy. You’ll need to be logged in as root to make sure it succeeds. Then try the upgrade again.

HTH
Norm

Thanks - that solved it.

The file config/config.php.orig must be deleted, in case you did that not already.

What an annoying update. On Sunday evening the download.nextcloud.com Let’s encrypt certificate expired and the updater script was not amused… I notified the team via IRC and Twitter but actually nobody was available to fix within the next 3-4 hours. With HSTS enabled also downloading with a browser was not possible and only a “wget --no-check-certificate https://download.nextcloud.com/server/prereleases/nextcloud-13.0.5.zip” helped to do a manual upgrade then.

I have similar problem on CentOS 7.5+ NC 13.0.4, I have revert to snapshot before the update. The stable channel update still produce the same error:

I have try to delete the file manually, but there are still many other files has same problem:

Could not rmdir: /var/www/html/updater/…/3rdparty/aws/aws-sdk-php/src/data/logs/2014-03-28
Could not rmdir: /var/www/html/updater/…/3rdparty
Could not unlink: /var/www/html/updater/…/AUTHORS
Could not unlink: /var/www/html/updater/…/console.php
Could not rmdir: /var/www/html/updater/…/core

After I delete core folder, it shown following and cannot continue anymore:

core/shipped.json is not available

…did the thing. I did not have to delete any file.

1 Like

You may be right. When I edit the config file as root, the backup file is created with root ownership. So your method may be even better.

Same problem with creating backup happened with another server. Same solution (chown -R www-data:www-data *) fixed it. Upgrading went smoth with no other problem.

I still do not see 13.0.5 in the production channel. Is that correct?
Is there a place where I can see the progress of the roll out of specific versions?

40

image

… obviously not!

If you klick ‘Install - Nextcloud’ in the picture of my previous post you will reach the source for download 13.0.5.

Good luck, kormorix

Thanks @kormorix , I could take your approach, but I would expect that the stable channel would serve the new releases for the ‘automated’ upgrade process (which I used until now for the upgrades). I would like to know why the new version is not detected. Is it a bug, or is version 13.0.5 still not rolled out to everybody?

I did not realize that there was a stable and production channel.
In the production channel the current version is still 13.0.4.
In the stable channel it is 13.0.5.