Nextcloud 12 Secure connection failed

I’m quite at a loss at what’s happening right now. I’ve had this instance of Nextcloud up since September, and have upgraded it to 11 and then 12 recently without issues. Completely out of nowhere today the web interface is completely inaccessible. This is running on Ubuntu Server 16.04. What was happening before this happened was I created a user that had dashes in their name “just-like-this” from the Users panel. I’ve tried restarting the server and apache. When the problem really happened was when I tried logging on as that user, in general and with Impersonate and that popped up an internal server error message. I can’t log in as anyone right now so the server is effectively down.

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):

Nextcloud version (eg, 10.0.2):
Operating system and version (eg, Ubuntu 16.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 5.6):

The output of your Nextcloud log in Admin > Logging:

The output of your Apache/nginx/system log in /var/log/____:

Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

Sorry for the messy message Jason :slight_smile: I included half that information but it’s cluttered in there.

Nextcloud version: 12.0.0
OS: Ubuntu Server 16.04
Apache version: Apache/2.4.18 (Ubuntu)
PHP: v7.0.18-0ubuntu0.16.04.1

Looking at the error.log for apache there is absolutely nothing related to my problem. The errors from these logs were created at different times that appear to be unrelated to this issue, but here are the logs from error.log:

[Tue Jun 20 13:45:27.619521 2017] [mpm_prefork:notice] [pid 635] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations
[Tue Jun 20 13:45:27.619689 2017] [core:notice] [pid 635] AH00094: Command line: ‘/usr/sbin/apache2’
[Tue Jun 20 13:47:02.992166 2017] [mpm_prefork:notice] [pid 635] AH00169: caught SIGTERM, shutting down
[Tue Jun 20 13:47:04.392633 2017] [mpm_prefork:notice] [pid 833] AH00163: Apache/2.4.18 (Ubuntu) OpenSSL/1.0.2g configured – resuming normal operations

The shutdown is from me restarting the server

1 Like

To add more information, this is what happened during my login process with nextcloud:

{“reqId”:"",“level”:1,“time”:“2017-06-20T22:05:11+00:00”,“remoteAddr”:“”,“user”:"–",“app”:“admin_audit”,“method”:“POST”,“url”:"/index.php/login",“message”:“Login attempt: “stratacast””,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0”,“version”:“”}
{“reqId”:"",“level”:1,“time”:“2017-06-20T22:05:11+00:00”,“remoteAddr”:“”,“user”:“stratacast”,“app”:“admin_audit”,“method”:“POST”,“url”:"/index.php/login",“message”:“Login successful: “stratacast””,“userAgent”:“Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0”,“version”:“”}

1 Like

Hmm I was hoping something relating to that user would show up in the nextcloud.log.

Me too to be honest. I did a snapshot just before toying around with my server, so if something goes even more to poop I can just revert back. I tried deleting the user from the command line too and that didn’t help. I thought perhaps it had to do with the files app even so I deleted that and replaced it. No luck there either. My SSL certificate is just fine, server is up to date and I can’t log in as any other user still whether the user does/doesn’t use TOTP. I can get to the login page still but that’s it

Chromium produces a different error:

This page isn’t working didn’t send any data.

After analyzing the nextcloud.log more, I see that the logins are successful but data isn’t being returned at all. What would cause that?

Turns out the only solution I could find was restoring from a backup. If any devs are interested in helping me solve the anomaly, I do have a copy of the damaged system I could play with @JasonBayton. Perhaps I should file this as an issue on the nextcloud github?

Yes please do. Getting to the root of it may stop it from happening to others :slight_smile: