Nextcloud 12 doesn't sync Google Drive - invalid scope

I would like to mount external storages to our Nextcloud. Our smb file server has been mounted correctly, there’s no problem. But I can not sync Google Drive. I have created the project, added Drive API, created credentials, got the client ID and the secret and specified the redirect URI. When I click on Give Access, it redirects me to choose a Google account. I choose my account and then it says error 400, invalid scope (invalid = []).

Have you got any idea? We use Nextcloud 12.

Same issue for me on nextcloud 12 just installed on debian stretch.

Solved by joining the group “Allow Risky Access Permissions By Unreviewed Apps” as suggested in the error message

Thank you very much!
The strange thing was that it was on. I need to set off this option on Google and set on again. But now it works. Thank you very much!

Hey guys.

Not longer able to join the group “Allow Risky Access Permissions By Unreviewed Apps”. Any other suggestions?

I get error 400 saying that {domain}/index.php/settings/admin/externalstora does not match the ones authorized, even though I’ve added the path in API console.