Nextcloud 11 seems to break gnome integration

I am running Ubuntu 16.04 with gnome-control-center installed. It seems like the update to Nextcloud 11 breaks the “online accounts” integration in Gnome. The mounted webdav folder works without any problem, but the integration of contacts and calendar into evolution mail does not work anymore. I get errors with the message

PROPFIND on webdav failed with HTTP status 404 (Not Found)

Which seems to be a problem with the URL. Default used by the integration is in my case<user>/<Contact list>/

and the one given by the contact app is<user>/<Contact list>/

However, manually changing the URL does not solve the problem. My phone and Thunderbird still works alright. Has anyone else noticed this, and how was it solved? Or is this something I should take up with gnome instead?

Thanks for all help


I had the same problem. I have removed the account and added it again.

Worked for me.


Hmm, strange. I have tried that already and it does not seem to solve the problem for me. I get a
HTTP error, not found
When evolution tries to connect to the calendar and contact lists. It fails completely and does not even find which calendars and contact list I have. Webdav integration of the file system works flawlessly still

I had this problem on my notebook. On my PC at work I had no issues.

Same Problem here: “HTTP error: not found” in Evolution calendar, no nextcloud calendar visible in Evolution OR the standalone Gnome Calendar, deleting and re-adding the account (several times not, hope dies last) did not help. Same goes for contacts. WebDAV working flawlessly.

/var/log/messages shows:
dbus-daemon[2932]: ** (gnome-calendar:23057): WARNING **: source_credentials_required_cb: Failed to authenticate ‘’: HTTP-Fehler: Not Found

I am 100% sure the credentials are correct.

When logging in via browser all calendars and contacts are there and my mobile syncs flawlessly via DAVdroid, so I assume the server-side is working correctly.

PS: I’m using Gnome 3.20.2

Perhaps you can have a look here …

I tried several alternatives, but Gnome only accepts URLs like “”. Any further specification (e.g. the links shown on the calendar site itself) lead to an error message.

I don’t think the link itself is the problem, because Gnome is happy with it and offers to sync calendar, contacts, files and documents. The only error appears in Evolution and the calendar/contacts apps.

I’m here on

local/gnome-online-accounts 3.22.3-1
Single sign-on framework for GNOME

Just updated to Nextcloud 11.0.1
Everything is up and running again. :wink:

1 Like

I have upgraded to 11.0.1 as well. Seems to work like a charm now

1 Like

I have this issue on Ubuntu Budgie 17.04. I can’t even use the standard sync client anymore. Don’t know if that is related. @MorrisJobke maybe you know someone that uses Gnome and have a fix for this? :slight_smile:

Maybe @jancborchardt :wink: But I guess you should do a proper report. “It doesn’t work” helps nobody to understand what doesn’t work. Anything in the logs? Does the window show up? What exactly is “broken”?

I will file an issue sometime this week. Thought the info on this thread was (maybe not enough) somewhat informative at least…