NexctloudPi on arm64?


I wanted to give Nextcloud on Raspberry Pi another chance after I had a really bad experience with it a few years ago and then used Seafile over it.
And to have the best possible performance I ordered the Raspberry Pi 4 with 8GB of RAM.
I stupidly assumed that the raspberry foundation would’ve released a 64bit Raspberry OS already but there is only a beta for the full os and I really just need the lite version.

So I was considering downloading the NextcloudPi image from here directly and install that. But nowehere does it say anything about the architecture. I would really like to fully utilize the full RAM and not be limited by the architecture.
Can someone confirm that that image would be installing a arm64 buster?

I downloaded and mounted the image and stupidly tried to grep the files (because I don’t know where in an image the necessary info lies for this) but found both armhf and arm64 in it.

Any help would be really appreciated. All the things are coming today and I really would like to set it up over the weekend.


Edit: So I received my pi4 and installed nexcloudpi and when I run arch or uname -m I get arm7l which appears to be 32bit arch. Now is there any way currently to get this running on raspi4? I saw there is a docker container, which would mean I would need to install the (full fat DE including) beta release os raspberry os 64bit to make it work, right? Or is there an relatively easy path to install a Debian Buster myself and then just use the docker?
If the answers to all these are no: How hard is it to migrate my raspberry later to a arch64 system? Lets say I install a 64bit nextcloudpi onto a new sd card in a few months, how hard is it to migrate everything?

1 Like

So you came here (nextcloud forum) to complain that there is no stable release of raspberry os 64bit yet?

Please take a minute to think about that…

Afaik you can use the beta release and you can put a file somewhere to run it in headless mode. However, there is some other unsolved issues currently regarding the 8gig ram version. Please search the forum here to learn about that…

Btw, id recommend the curl installer over the docker version, as docker adds another layer of complexity and if you are not docker savy it will most likely cause you problems

Hello FladeFx, thank you for your response. I did not come here to complain, no. For sure I was not coming here for your condescending tone. (I guess that little intro is necessary for some)
I was asking the community what architecture nextcloudpi was made for after following the “community” link on the ownyourbits website.

I did not come here to shit on nextcloud nor the raspberry foundation, but just to ask the community for help. I am sorry if I came off like I was just complaining.

As long as there is no stable RaspberryOS release for arm64 we should not expect an official nextcloudpi image i guess. However, the curl installer i mentioned is suitable for any debian based OS and will work well on RaspberryOS as soon as the problem i mentioned earlier gets ironed out

I would like to suggest

I’m using this 64bit OS in combination with openmediavault for management of the Raid mirror.
Nextcloud (fpm), MariaDB, Letsencrypt, redis and Dnsmasq running in docker container.

Runs smooth on a RPi4 with 4 GB RAM.

1 Like

That sounds great, thank you will look into this and report back.

Still there is the problem of nextcloudpi in combination with the 8gig rpi4, look into that issue before doing anything, i am not sure if it is solved yet

Okay nevermind, I got it to work by just installing the raspberry pi image of ubuntu server 20.04 64bit and then just installing nextcloud via snap and then following this dude’s guide.

So does all work properly?
have you been able to get only office or colabora running?

Neither OnlyOffice nor Collabora run on ARM architecture server installations of Nextcloud at all. This is well documented and simply not an option at this time. To run either, you must either setup an x86 tower machine or pay for a VPS to host it on Digital Ocean or similar. Good luck!

I certainly hope future iterations of Collabora will support ARM, as mentioned here on Github. OnlyOffice has switched away from a fully open license, so your best bet is to just jump ship on them if you hope to self host (or pay for their new licensing model).

edit: added a request for arm64 Collabora CODE architecture support as well.

1 Like

Mh it does, but not with nextcloudpi. The snap stuff gave me problems and then I installed the docker image (two times) which ended in desaster as well. I tried that install script, which is tailored for debian however and I was not in the mood of adjusting packages and other stuff.

I now do have a very stable installation on my ubuntu server 20.04 after following this dude’s guide. This was an interesting experience and I hope I never have to deal with PHP besides this, but it is now running very smoothly. I don’t know what I do if the slightest thing goes wrong because the setup seemed quite fragile, but these worries are offset by how stable it runs. I have tried out nextcloud over the years again and again and it used to be a real bad experience every time (esp. compared to my super stable seafile), but now all looks well.

Did it ever use more than 3GiB? Nope. slightly above 3 is as much as I can see, but I do not care about this anymore. It was a dumb idea of mine to buy a 8GB raspi just because I thought nextcloud would benefit from that. Netdata also shows me that not even the system as a whole ever benefitted from that as the whole system never consumed more than 3GiB…

I did not try out any office packages as I think they are not supported on arm64.

Basically: It is not worth of going through the hassle of getting arm64 to work with nextcloud as there is no benefit, but that guide linked above is really well made.

@Spekkk I’m going to completely disagree with you here, as I’ve been running arm64 docker builds of NextcloudPi for years. I’m using an Odroid (hence the long term support for arm64), but I’ve had no issues with switching to NCP’s arm64 builds for odroid at any time. It works perfectly. Only issue I’m aware of is the Raspberry Pi foundation taking so dang long to switch over to arm64 architecture and finally releasing the Pi 4.

I do not run the Pi 4 myself, but I can tell you the issue is not with arm64. The issue is with Pi taking forever to embrace it. If you run into issues, please report them here on the NextcloudPi github page.

1 Like

Look I don’t wanna shit on anyones work. I really appreciate the work everyone put into this. But everytime I installed nextcloudpi on a pi, I ran into problems eventually, I got errors in the webinterface or when I was uploading stuff in the client. It was a super unstable experience. That might just be my own stupidity since everyone else seems to just do fine with it.

With respect to the docker image, the instructions linked on the main page are from 2017 and marked as outdated. The linked newer document also from 2017 and does not contain all necessary info like the older document. So this is already a bad start. If you go into the documentation, there is yet another page with docker instructions. Even if everything worked out, I don’t know if I would want to rely on this. Little info about how everything works together. E.g. in the docker image, what stops me updating the 18.x nextcloud to 19.x? Well you can certainly start the updating process and right before the final step, nextcloud lists that the nextcloudpi app is incompatible, but there is no way back. And pressing the “update” button results in an update loop. If you want support, you are not just using nextcloud. You are not just using nextcloudpi. You are using some container that someone set up with nextcloudpi in it. Getting support for this or debugging gets really hard.

All I am saying is: If you hide complexity behind an abstraction level like a container, the thing must run absolutely flawlessly. If you see some problems in the logging settings or it is asking for a package that is missing, how do you maintain this in a docker or snap image? You just don’t have any visibility about the setup because everything has been done for you.
I joked above that the manual setup I followed feels fragile because I set everything up myself, but actually I can understand most of what I did (besides these PHP optimizations). I know what was installed and how I can debug this when things go wrong.

Its a little bit like using Arch over e.g. Ubuntu or Fedora: You set up everything yourself and learned along the way why things work the way they do. So when things break you are more likely to understand what is going on and how to fix it. Just the difference here is that mainstream linux distros like Ubuntu or Fedora are much more stable nowadays. So you don’t have to know how everything works together (although it helps). In my experience this is not the case with nextcloud(pi).

As for arm64: The raspberrypi foundation should’ve started with a arm64 when they released the pi4. It is a little crazy that they didn’t. (But they are probably also very busy.) I think using it as a (media) server is the #1 use case for many and can benefit from 8GB RAM. But in my case I use a Ubuntu Server 20.04 for arm64 from canonical. So not really any problem with “pi not embracing” the architecture.


Sorry i read not everything. But perhaps you can use Nextcloud with Ubuntu 20.04 LTS and this installation guide without Snap or Docker.

If you like apache2 more then nginx use parts of this installation guide for Debian GNU/Linux

As I wrote above, I already installed everything myself now and it works. Thank you.

Yes I’m aware of the documentation, that Colabora and OnlyOffice only run on x86 but there no other otions?
I have found this Post about QEMU for emulate a x86 Processor in arm64. I 'll try this, just for my personal education.

Thanks for this information, so I try Collabora first.

I my self had also serveral problems with getting Nextcloud running.
First I tryed nextcloudpi, but this dit not work, I dont remember what exactly did not work but I could not evan finish the installation, I think the activation process dit not work.
Then I tryed with snap on the Raspberry Pi OS and this also did not work.
Then I found this Guy’s guid and with this I could set it up and running.

I think ther is an issue with the 8GB RAM version of the Pi 4.

Really good points! Definitely agree that the only way to learn and understand the system is by building it yourself.

In this case, you have to log into your docker container to install packages, etc.

docker exec -it nextcloudpi bash

These changes can be submitted to the Nextcloudpi github page. They also have a documentation team, but it could certainly use more updates in relation to the main website. :slight_smile:

Yeah, it is riding that line of “be as helpful as possible” by making some decisions for you.

They do have an excellent community chat and the biggest benefit of their offering is maintaining a very conservative release cycle. Things do break when upgrading versions, especially if you are not involved in their chat group… I’ve balanced this by maintaining a secondary Odroid device I use just for possible upgrade breakage tests.

Glad you found a setup that works well for you! :exploding_head:

Thank you for your helpful response! I will keep an eye on this!