Nexctloud data folder not backing up

Hello Folks,

I am a happy user of nextcloud… I have created a rsnapshot cron job to backup the entire nextcloud data folder. My rsnapshot routine works fine with other folders but not with the nextcloud data folder. Do I have to change anything with the privileges??? ANy idea…


backup nuc/
backup nuc/

The second line is backed up, not the first one…


What do you see if you run the commands without Cron? I’d imagine it’s file ownership, in that “Edwin” doesn’t own the NC data directory.

Can you run the command from the server to a remote location? You could then put the commands in the root Cron and it should work.

Thanks for your help, Jason! When I run the command without Cron, it just does the same. Rsnapshot works. I have tried to backup /etc alongside the nextclouddata folder and only etc is backuped.

I am pretty sure it is a file ownership issue. Can I just add Edwin to the www-data group???

I cannot run the command from the server to a remote location as Rsnapshot is pull based only.

Yes, if that’s what you want to do… alternatively you could perhaps create a zipped tar of the directory into your home drive and do backups that way? One file to pull rather than everything and no permission issues.