Nexctloud Client won't update on KDE Neon 20.04

Nextcloud won’t update on KDE Neon to 3.1.0 because of qtbase-abi-5-12-8, which doesn’t exist.

Any idea how to fix this?

2 Likes

After some exploring, qtbase-abi-5-12-8 is normally supplied by libqt5core5a but this is already installed in Neon by default. Neon’s current version as of this post is 5.15.2+dfsg-0xneon+20.04+focal+build23 which suggests that the Nextcloud package is not finding qtbase-abi when it is using a newer version than qtbase-abi-5-12-8.

I’m guessing that the qtbase-abi version is in someway hardcoded?


While it isn’t the latest version, current versions can be installed in Neon with:

pkcon install dolphin-nextcloud

Unfortunately, dolphin-nextcloud depends on nextcloud-desktop so that’s a no-go.

You can try to install the AppImage from Install – Nextcloud . It worked for me

As another option, Flathub has version 3.0.2 as of this writing.

But we loose file manager integration with the AppImage / Flatpack / Snap, right? Is there a way around it?

Right now, I just have mine on hold. Hopefully this gets resolved.

I’m still running into this, KDE neon 5.21 and the official Nextcloud repository. Only solution I’ve found is to download the deb sources and build the debs myself.

Am on Neon, too. Found this solution building a fake qtbase-abi package to fit my needs: PPA install: Dependency resolution issue on KDE neon 20.04 regarding QT 5.15.2 · Issue #2722 · nextcloud/desktop · GitHub

nextcloud-desktop installable afterwords and works perfectly…

BR,
Marsellus

Perhaps we can try the nextcloud version for Hirsute from this PPA Desktop client : “Nextcloud development” team . Ubuntu 21.04 has Qt 5.12.2, the same as Neon focal

Any brave person with time want to try it?