Nexcloud 2.0.6 snap1 - Collabora Online still not working?

I would like to know what is a situation about Collabora online?
I have Ubuntu 20.04 server + Nextcloud 2.0.6 Snap 1 and I see that problem with using of Collabora online still persists (slowdown/timeout) from version NC 2.0.1…
When it will be finally fixed?
I need some tool for online editing of documents but Collabora integration seems to be a bad step for Nextcloud.

Where can I find some solution on how to resolve this?
What are other options for online editing?
Thank you for your reply.


I think we have the same problem. I have a snap NextCloud in a 20.04 web server. I can upload libreoffice files (.ods and .odt), yes. But I cannot open them. If I try to open them, a notice at the upper right corner of the screen pops out saying “connection to server lost”. I can download them, no problem. But I think it’d be great if we can view them online right there and then, and have other people collaborate on them.

So, are there any solutions for this, NC community?


After some googling and some trial and error, I was able to solve it. My NextCloud Snap didn’t have the nextcloud.enable-https lets-encrypt because I was using a certbot-installed ssl certificate via apache2 virtualhost on the same server. So what i did was this, I revoked that certificate (certbot revoke --cert-name Then back to Snap, I ran the nextcloud.enable-https lets-encrypt command and got a new cert. Now my Collabora Onlinei is working and i can view .odt, .ods files, etc., and even collaborate on them.