News App stoppt working

after updating my News App somewhere Mid/End of December my news App stopped working. First I thought it’s christmas time but now I’ve checked logs and see a lot of errors:

"Exception":"TypeError","Message":"Return value of OCA\\News\\Scraper\\Scraper::getContent() must be of the type string, null returned","Code":0,"Trace":[{"file":"/var/www/cloud.jakobssystems.de/apps/news/lib/Fetcher/FeedFetcher.php","line":125,"function":"getContent","class":"OCA\\News\\Scraper\\Scraper","type":"->","args":[]},{"file":"/var/www/cloud.jakobssystems.de/apps/news/lib/Fetcher/Fetcher.php","line":76,"function":"fetch","class":"OCA\\News\\Fetcher\\FeedFetcher","type":"->","args":["http://blog.tempel.org/feeds/posts/default?alt=rss",false,null,true,null,null]}

with error messages (I’ve left the blog link intentionally undisclosed for debugging)

Unable to parse content from http://blog.tempel.org/2014/05/xojo-cocoa-animation.html

these are repeated several times and then the processing of all other feeds stops so that no feed at all is processed. This shouldn’t be!

I am missing missing something?

Remove the feed from your list. It seems to contain code which makes it incompatible with a wide range of feed readers, including the News app:

https://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fblog.tempel.org%2F2014%2F05%2Fxojo-cocoa-animation.html

For many reasons I do not accept this workaround.

First: It worked before

Second: Then I have to kick out a lot of more feeds too because they are making same error mesages. Take another feed, maybe one with more weight in his name: MSDN Microsoft Blog RSS Feed: https://blogs.msdn.microsoft.com/commandline/feed/

Corresponding error News Feed Error Message:

message":{"Exception":"TypeError","Message":"Return value of OCA\\News\\Scraper\\Scraper::getContent() must be of the type string, null returned","Code":0,"Trace":[{"file":"/var/www/cloud.jakobssystems.de/apps/news/lib/Fetcher/FeedFetcher.php","line":125,"function":"getContent","class":"OCA\\News\\Scraper\\Scraper","type":"->","args":[]},{"file":"/var/www/cloud.jakobssystems.de/apps/news/lib/Fetcher/Fetcher.php","line":76,"function":"fetch","class":"OCA\\News\\Fetcher\\FeedFetcher","type":"->","args":["https://blogs.msdn.microsoft.com/commandline/feed/",false,null,true,null,null]},

And last but not least Why on earth can a single news feed kick out the whole processing of Newsfeeds? This doesn’t sound trustworthy to me, does it?

is it possible that special characters within these feeds causing this problems?
watch this screenshot of the MSDN Feed:

I think this could indeed cause problems depending on how the code is interpreted. Eventually it would be worse to file an issue report in the News app repository.

I do not have a github (and no facebook, whatsapp, google or microsoft!) account. (and I won’t get one). Could anybody please file an issue with link to this thread?

1 Like