New versions not available on a NC v20.0.14 instance

Nextcloud version (eg, 20.0.5): 20.0.14
Operating system and version (eg, Ubuntu 20.04): GNU/Linux but couldn’t find more details
Apache or nginx version (eg, Apache 2.4.25): Apache but couldn’t find the version
PHP version (eg, 7.4): 7.2.34

The issue you are facing: My Nextcloud instance is on version 20.0.14. When checking for new version in the updater (under Settings > Overview), it is written Version is up to date (the tooltip shows that it was checked a minute ago). The selected “Update channel” is Stable.
I expect newer versions to be shown here.

Is this the first time you’ve seen this error? (Y/N): Yes

Steps to replicate it:

  1. Go to Settings > Overview
  2. Check below Version

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'ocamw6vapk73',
  'passwordsalt' => 'xxxxxxx',
  'secret' => 'xxxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => 'cloud.xxxxxxx.xxx',
  ),
  'datadirectory' => '/home2/xxxxx/public_html/new_nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '20.0.14.2',
  'overwrite.cli.url' => 'https://cloud.xxxxx.xxx',
  'dbname' => 'xxxxxxx_newcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxxxx_newncld',
  'dbpassword' => 'xxxxxxxxxxxxxxx',
  'installed' => true,
  'mail_domain' => 'xxxxxx.xxxx',
  'mail_from_address' => 'cloud',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_smtphost' => 'serv7.wxxo.com',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'xxxxxx@xxxxxxx.xxx',
  'mail_smtppassword' => 'xxxxxxxxxxxxx',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'updater.release.channel' => 'stable',
);

It looks like you’re using PHP version 7.2, which is the oldest version of PHP that NC20 supported[1]. In order to upgrade to NC21 you’ll need to get to at least PHP 7.3, but 7.4 and 8.0 will also work[2].

The system won’t offer you the upgrade option until your environment’s PHP meets the requirements. If you upgrade (or switch, if applicable) your PHP to 8.0 you should be able to make it all the up to NC26[3].

[1] System requirements — Nextcloud latest Administration Manual latest documentation
[2] System requirements — Nextcloud latest Administration Manual latest documentation
[3] System requirements — Nextcloud latest Administration Manual latest documentation

1 Like

Thank you very much for your response and apologies for the late reply.

I’ll try upgrading my PHP then. I’ll leave another comment later in this post to share the result.