New version Client: 'There are unresolved conflicts'

Xubuntu 18.04
Client 2.5.0git
RPi based Box with Snappy Nextcloud

After the new client installed (2.5.0git) all still works but instead of the green ticks I now have yellow ‘!’ marks with the message, ‘There are unresolved conflicts. Click for details.’

However, these ‘unresolved conflicts’ are all just ‘File/Folder is on the ignore list’ or ‘File/Folder is ignored because it’s hidden’.

I have, and always have had, the ‘Sync hidden files’ box unticked
I tried ticking this but it still showed the same (with only ‘File/Folder is on the ignore list’ errors as expected)

Is this behaviour now normal?

Surely, if files are supposed to be ignored then a warning isn’t necessary?

Not the end of the world but I do miss the satisfaction factor of seeing nice plump green ticks :slight_smile:

Thanks

Leigh

1 Like

I am get the same issue after Nextcloud client upgrade on my Kubuntu 18.04.
I believe that it shouldn’t be correct behavior,

This Desktop Client search for file names with ‘_conflict’ into the name.
If you delete this files, you should not get this message again.

1 Like

Tried that but still same problem

I have since found out that here is an open issue on this

1 Like

@mr-bolle - well initially deleting all the conflict files didnt work but a few syncs later I have green ticks again :slight_smile:

I did also reset to defaults in hidden files options after deleting files, but not sure if this was part of the solution

Thanks!

To fix the issue, I also had to completely close the Nextcloud client and re-open it. After a rescan, it figured it out and now gives me the green “tick” icon

1 Like

I’m having exactly the same issue — just updated to latest NextCloud client on my Mac and I’m being told there are conflicts and I’ve got the exclamation mark. Clicking on “There are resolved conflicts” does absolutely nothing. A search for anything with _conflict in it returns nothing.

Any other ideas?

(In case this will help others)

OK – turns out that there were files with _conflict in them. However, they were inside app and other packages and the regular spotlight search does not find these. I had to resort to other tools to discover them. Once I got rid of them, the icon went green – note that I did not have to restart the application

Would be nice to know what you used or did to find the files with ‘_conflict’ in the names.

Telling us that you resolved your issue is great, but not telling us how you did it really isn’t helpful.

2 Likes

@dhjdhj Hello David, would you kind to other to share the way that you used to locate the “_conflict” files ? Thank you for all who struggle with that :sweat_smile:

In GNU/Linux, and in theory MacOS, one can use the find utility to find all files containing “conflicted copy” and delete them.

Find all conflicted copies in the home directory and delete them:

find ~ -iname "*conflicted copy*" -delete

Find all conflicted copies in the current working directory and delete them:

find . -iname "*conflicted copy* -delete

This helped me. You should manually review important files just to be sure. They really need to program this so it finds conflicted based on their checksums…

My experience with conflicting files was, to take a detailed view into the files before deleting them. Sometimes a conflicting file may be more recent than the “original” file. Data files should be opened and checked for the latest changes.

In Owncloud very often the conflicting files were ok but the “original” files were damaged (a few bytes smaller than conflicting files) and could not be opened by MS-Excel or Word anymore. - In Nextcloud I never had this consistency-problem, but you never can be sure…

So, be careful.