"new" Upload progress bar in NC 28.0.2 not working when chunk size set to --value=0

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 28.0.2.5
Operating system and version (eg, Ubuntu 20.04): ubuntu server 22.04.3
Apache or nginx version (eg, Apache 2.4.25): NGinx 1.25
PHP version (eg, 7.4): 8.2.15

The issue you are facing:
uploading files do not show any progress bar but an empty bar with a hint

Is this the first time you’ve seen this error? (Y/N): Y (since NC 28)

Steps to replicate it:

  1. using NC 28 with Firefox 115 ESR on linux

  2. using WebUI for upload a iso file e.g. gparted live cd just some MB large

  3. disable all Add Blocker (e.g. uBlock Origin)

The output of your Nextcloud log in Admin > Logging:

no logs / no error just no progress bar or upload infos

The output of your Apache/nginx/system log in /var/log/____:

no logs

PASTE HERE

no errors

The upload finishes successfully but for larger files e.g. a zorinos 17 pro has 5-6 gigabyte in size you absolutely don’t see anything when upload will finish.
some php parameters missing?

1 Like

I can not reproduce that:

Dateien---Nextcloud


ernolf

Thanks for reply, no can’t see what you see!

Have downloaded a testfile 250 MB
from here and testet in userdir, groupfolder, and shared upload
allways the same. No progress bar, no counter of already uploaded size and still needed time to finish, nothing. I just see a blank bar and the text below doesn’t change.

After a period of time - concerning the uploaded file size - the bar and the text vanish and the uploaded file appears as newly uploaded content. So the upload itself seems to work but without the information i can see in your video i am “blind” concerning upload progress.

The “brider” upload bar till NC 27.x worked till 27.1.6 as expected.

Identical symptoms here as well, went from 27 to 28 and upload progress bar no longer updates.

1 Like

Thanks! Good to know not to alone with that.

I had several problems after update e.g. missing *.mjs support in my NGinx config, as well as little probs with the logfiles reader because of just having uBlock Origin installed. Deactivating this brought me back to game concerning opening the logfile admin page without any messages.

I hope that this problem also is caused by a java / php setting that is missing or wrong. I posted my config several times here in the last few days so the way from 27 to 28 was a (harder) step by step procedure for me :smiling_face:

I think i have found the clue … (needs to be verified)

When setting the chunk size to --value=0 then you “kill the progress bar of nextcloud 28”

https://docs.nextcloud.com/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html#adjust-chunk-size-on-nextcloud-side

Setting my chunk size to a value e.g. 20971520
by command
sudo -u www-data php occ config:app:set files max_chunk_size --value 20971520

then the upload progress works as shown in the video by ernolf but sending large files with a longer waiting period at the finish of the upload.

So my question - why that dependency between chunk size and upload progress bar?

The official manual still says a chunk size of --value=0 is ok (optional usable)
But not in case using the new upload progress in NC 28.
Bug?

In some cases you can crash the whole client when uploading very large files using a chunk size of --value=0 tested - but just here - reproducable.

1 Like
sudo -u www-data php occ config:app:get files max_chunk_size

returns no output for me.
perhaps it isnt being set at all for default nc28 deployments.

you’ll have to set a value!

see manual i have linked for you

without a value number it won’t change your config

# sudo -u www-data php occ config:app:get files max_chunk_size
# sudo -u www-data php occ config:app:set files max_chunk_size --value=1048576
Config value max_chunk_size for app files set to 1048576
# sudo -u www-data php occ config:app:get files max_chunk_size
1048576

you’d think it would still return a default value, returning null in any programming language isn’t the way.

never the less, have you tried to change the value?

After i have changed it from 0 to the 20MB the bahaviour of my progress bar changed as well. Not my purpose because i was happy with chunk size 0 because of very fast finishing large uploads.

And i made a restart of the server after changing it!

yes, as indicated above.

out of interest @chrissi55, are you running mpm_prefork or mpm_event? the reason i ask, is that in firefox dev tools - i receive this when i cancel the upload:

it appears all ‘chunks’ are being fired at once… rather than one after the other - explaining why theres no progress updates (none of them have finished).

uploads actually do work - just no progress updates.

In some cases you can crash the whole client when uploading very large files using a chunk size of --value=0 tested - but just here - reproducable.

using zero means that php will not return a status until the file is uploaded entirely, in this case if the file exceeds the max process size set for your php session it will fault.

isn’t that an apache “thing”?

I am using nginx for reverse proxy and webserver

But i have just set chunk size back to 0 and voila reproduce that the progress bar is “broken”.
Set it back again to a value (i have chosen the value from the admin manual) then progress bar is working but uploading large files becomes a “waiting game” :roll_eyes:

its internal to php, prefork/event are threading related…

i am not sure where to look at?

I have nothing configured like this one
https://www.digitalocean.com/community/tutorials/how-to-configure-apache-http-with-mpm-event-and-php-fpm-on-ubuntu-18-04

mpm_prefork and mpm_event are two “Multi Processing Modules” (mpm) from the apache2 server and are not php internal.

libapache2-mod-php relies on the old but stable Multi-Processing Module (MPM) “mpm-prefork”.
php-fpm relies on the more scalable threaded MPM “mpm-event”.

nginx uses php-fpm per default.

If not set, the default value (10MB) is used:


ernolf

@ernolf

yes i use php-fpm

Should we have a bug report for the “progress bar” at github?

Here is the part, where the magic is done:

feel free to open a new bugreport if you find the reason for the behaviour you observe or if you are able to reproduce it on more than one server or if you feel absolutely sure about your issue.

I have various server instances in virtual machines, with apache, nginx, mysql, postgresql etc. but none of them shows the behaviour you described.

Of course you can wait and observe the issue tracker for someone else opening an issue…


ernolf

that means chunk size value=0 is working for you?

OK, now you have me. I thought too quickly that it didn’t matter because it didn’t work for @barrystyle even without the value 0. But it’s true, if the chunk size is set to 0, the progress bar doesn’t work.

You can open an issue and i will support it with a :+1:


ernolf

1 Like

I’ll do my very best :innocent: