New LDAP users not added to LDAP Groups in Nextcloud

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.6
Operating system and version (eg, Ubuntu 20.04): 20.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.41
PHP version (eg, 7.4): 7.4.3

The issue you are facing:

Previously my LDAP users would populate in Nextcloud with the appropriate LDAP group membership assigned on the LDAP server. New users are not being added to the LDAP group inside Nextcloud. If I even try to manually add a user to the LDAP group inside Nextcloud’s Users section, it will not allow me to select any of those groups.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Add User to LDAP/Email server.
  2. Add new User to LDAP group/Mailing list.
  3. User shows added in Nextcloud.
  4. User does not belong to any group that was created on the LDAP server.

Hi @mcoulter -

You didn’t provide a lot to go on. Previously meaning when? A different NC version? A different NC server?Also, providing your LDAP configuration would be helpful. :grin:

https://docs.nextcloud.com/server/latest/admin_manual/configuration_user/user_auth_ldap.html#groups-tab

Let me restate with some new information. When I said previous before, I don’t think it was related to any different component versions than I listed. So I am not sure when the change occurred but I have sense upgraded to
NC: 27.0.1 and 27.1.0
Ubuntu: 22.04
Apache: 2.4.52
PHP: 8.1.2

Still same experience initially. The groups on the LDAP server show up in Nextcloud Users and the user will show up under the Active Users section but not in the corresponding LDAP group with the other users. They eventually do show so I don’t know if there is a polling timer that helps this along somewhere but it seems to take awhile to resolve. I’m not certain if it doesn’t even require me to drop and add the person back to the Group in LDAP but I’m seeing something triggers it to resolve eventually. It would be nice if that was a faster process if it is happening automatically. Not sure if anyone knows a way to speed that up.