Ncp-update errors

Had unattended upgrades on and I kept getting notifications that python3 was installed about every hour.

logged in via ssh to see what was up.

Tried disabling unattended upgrades and got an error message that said my swap file was full, so I increased its size and kept it mounted at /var/swap

rebooted machine

tried ncp-update and I’m getting this error

pi@nextcloudpi:~ $ sudo ncp-update
Downloading updates
Performing updates
jq: error: Invalid escape at line 1, column 4 (while parsing '"'"') at , line 1:
.params[2].value = "''/matthew_nelson/MyCloudEX2Ultra/Matthew/'"
jq: error: syntax error, unexpected $end, expecting QQSTRING_TEXT or QQSTRING_INTERP_START or QQSTRING_END (Unix shell quoting issues?) at , line 1:
.params[2].value = "''/matthew_nelson/MyCloudEX2Ultra/Matthew/'"
jq: 2 compile errors

matthew_nelson/MyCloudEX2Ultra/Matthew/ is a folder location where I have an NFS mount established through fstab setup. Wondering what’s going on.

also from nc-info, my PHP service is down and I’m getting a 503 error.

Thanks.

Edit: corrected what was installed

Apache3 sounds interesting :wink:

The current version is 2.4.38!

might have been python, can’t remember and cannot access because server is in maintenance mode : \

Tools>nc-maintenance
allows you to turn it off and on.

tried that, didn’t do anything.

It’s something to do with letsencrypt. my cert expired and it’s trying to put it all into another directory with the same dns location but appended with -0001

walking through the letsencrypt script now to figure out all the .config stuff that I need to review. any suggestions on where to go from here?

PHP services are working now, but ncp-update is still throwing errors. It was something with letsencrypt. is spelled my username wrong and notifications were not being pushed to me that there were SSL renewal errors.

Got it all straightened out by a combination of following the wiki for Letsencrypt, as well as the code for letsencrypt.sh

Just had to adjust some .config files, restart apache2 and php7.2. Back up and running now but still getting these damn errors when executing sudo ncp-update. Looking at the script that is giving me the errors, it still has something to do with Letsencrypt ==> line 222 of update.sh.

I’ve checked /usr/local/etc/ncp-config.d/letsencrypt.cfg and everything looks fine.

my letsencrypt.cfg settings

{
“id”: “letsencrypt”,
“name”: “Let’s Encrypt, Automatic signed SSL certificates”,
“title”: “letsencrypt”,
“description”: “Automatic signed SSL certificates. Let’s Encrypt is a free, automated, and open Certificate Authority.”,
“info”: “Internet access is required for this configuration to complete\nBoth ports 80 and 443 need to be accessible from the internet\n\nYour certificate will be automaticall$
“infotitle”: “Warning”,
“params”: [
{
“id”: “DOMAIN”,
“name”: “Domain”,
“value”: “something.something.org”,
“suggest”: “mycloud.ownyourbits.com
},
{
“id”: “EMAIL”,
“name”: “Email”,
“value”: “something@protonmail.com”,
“suggest”: "mycloud@ownyourbits.com
},
{
“id”: “NOTIFYUSER”,
“name”: “Notify user”,
“value”: “matthew_nelson”,
“suggest”: “ncp”
}
]
}

when I go to /usr/local/etc/ncp-config.d and run line 223 of the script, it comes back with:

root@nextcloudpi:/usr/local/etc/ncp-config.d# jq -r ‘.params[2].value’ letsencrypt.cfg
matthew_nelson

so I’m not entirely sure what’s up. It should be setting USER=matthew_nelson but it’s not when I run ncp-update.

Any ideas?

Upon restart, now PHP7.2 services are failing to load…

systemctl status

pi@nextcloudpi:/ $ systemctl status
● nextcloudpi
State: degraded
Jobs: 0 queued
Failed: 1 units
Since: Thu 1970-01-01 00:00:01 UTC; 49 years 2 months ago
CGroup: /
├─user.slice
│ └─user-1000.slice
│ ├─user@1000.service
│ │ └─init.scope
│ │ ├─1359 /lib/systemd/systemd --user
│ │ └─1362 (sd-pam)
│ └─session-c1.scope
│ ├─1344 sshd: pi [priv]
│ ├─1388 sshd: pi@pts/0
│ ├─1391 -bash
│ ├─1515 systemctl status
│ └─1516 pager
├─init.scope
│ └─1 /sbin/init
└─system.slice
├─fail2ban.service
│ └─1316 /usr/bin/python3 /usr/bin/fail2ban-server -s /var/run/fail2ban/fail2ban.sock -p /var/run/fail2ban/fail2ban.pid -x -b

service php7.2-fpm status

pi@nextcloudpi:/ $ service php7.2-fpm status

● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled; vendor preset: enabled)
Active: failed (Result: timeout) since Sat 2019-03-30 23:27:25 UTC; 6min ago
Docs: man:php-fpm7.2(8)
Process: 443 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize --fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=killed, signal=TERM)
Main PID: 443 (code=killed, signal=TERM)

Mar 30 23:25:35 nextcloudpi systemd[1]: Starting The PHP 7.2 FastCGI Process Manager…
Mar 30 23:27:25 nextcloudpi systemd[1]: php7.2-fpm.service: Start operation timed out. Terminating.
Mar 30 23:27:25 nextcloudpi systemd[1]: Failed to start The PHP 7.2 FastCGI Process Manager.
Mar 30 23:27:25 nextcloudpi systemd[1]: php7.2-fpm.service: Unit entered failed state.
Mar 30 23:27:25 nextcloudpi systemd[1]: php7.2-fpm.service: Failed with result ‘timeout’.

Still unable to get ncp-update working either.