NCP - Unresposnsive after attempting an upgrade

Last night I logged on to the NCP web interface and saw there was an upgrade available, so I clicked ‘Apply’.

Everything ran OK, until it required user intervention, but being a read only console on the web ui there was no way to provide this.

I believe the problem was php.ini differed from that in the upgrade so did I want to keep mine, keep theirs or edit. Unfortunately it was late and I did not think to copy the exact error.

Logging on via SSH I was greeted with

NextCloudPi v1.16.0 is outdated
update to v1.16.4 through 'ncp-config' or type 'sudo ncp-update'

So I tried sudo ncp-update, but received the error
apt is currently running. Try again later

How can I stop the currently running apt so I can re-run the update from ssh and get past the user interaction?

Also, when I get to the choice again I assume I should keep the local changes to php.ini?
I’m running the NCP image on a Pi3 with no modifications by myself, other than to change the apache virtual hosts to change the nextcloud url.


Typical, I rebooted (which I’m sure was the first thing I did last night… but clearly not) and tried again and was told what to do

For reference

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

I then selected to keep my local changes and ran.

sudo ncp-update

Everything then worked.

1 Like