NCP on a RockPro64

@nachoparker I want to test the image, too. Can you provide it for me, please.

ownyourbits.com/downloads

let us know how it goes

thanks! I will try it on the weekend.

@nachoparker It is working like a charme! Great work!
Don’t know if I should open another thread or if can ask here what to do for moving from my old pi to the rockpro with a new hdd.
My thoughts are: full backup the old instance; put the old hdd in the rockpro, mount it and then just restore the backup.

great! yes, backup and restore sounds good, I think there’s good info here

docs.nextcloudpi.com

My RockPro64 doesn’t boot up. I md5 checksummed the file and it is proper. I also formatted the SD Card and flashed with Etcher. I tried different RJ45 cables but with no luck. I can hear the drives run but I can’t find the RockPro64 on my network.

After some trying around with pwr and reset buttons it finally started. But now it is stuck somewhere.

do you have the same revision as @Christian_Schulte_ge ?

Do you mean hardware revision? I can’t find what @Christian_Schulte_ge has.

I will look what mine is… Should it be printed on the board itself?

My setup:
RockPro64
2*3TB HDD connected via SATA

My boards says: “RockPro64 V2.1 2018-07-02”.

I used “dd” like described in the documentation. Like this a white text says: “starting version 232”. I think this is GRUB. When I then push the reset button I see all the text going down to some point where it stucks again.

Do you want me to take a video?

no need, well this is experimental even in Armbian. Maybe try to install their latest image and get NCP from there

my version is 2.1 2018-06-06
But I only have one external 2TB HDD on the USB 3 port.

You are right I tried to boot without the drives connected and all seemed to work fine. I then tried to connect the SATA drives but NCP couldn’t recognize them.

Is there a way to file a feature request?

take this to the Armbian forums. I would try their latest image first

I am having the same issue with Armbian. Have not had time yet to do some research and troubleshooting. Will post here once I have more details.

1 Like

Thanks @Jeffrey_Frederick

Just wanted to add some personal data points to this thread:

I purchased a RockPro64 with the NAS enclosure and their PCIe to SATA card. After flashing the current NCP image (dated March 10, 2019) for the RockPro64, I was unable to get the board to boot with a hard drive attached to the PCIE SATA card.

With just the SATA card plugged in, and no HDD attached to it, the board would boot normally, I could access the NCP web interface and everything worked as expected. I connected a screen to the board, and on the terminal with dmesg I could see the SATA card being detected, and there were messages about the PHYs shutting down, presumably because nothing was attached to them. Attaching a hard drive (I tried several, including SSDs and HDDs) to the SATA card always resulted in the boot never completing, and instead of the normal boot messages being displayed, the screen just showed something to the effect of “Please wait, loading build ###” (I forgot to write down the exact message). I let it sit for several minutes and the boot did no proceed past this point.

I then loaded the latest (https://www.armbian.com/rockpro64/) Armbian Bionic image, and with that I was able to boot with a hard drive attached, see the SATA device, and mount it as expected. Because that worked, I then loaded the latest Armbain Stretch image, and that too booted with a hard drive attached, and I was able to mount and use the SATA device as expected.

Since the latest Armbian Stretch worked with the SATA card, I then ran the NCP install script. After it completed, I was still able to boot with a hard drive attached to the SATA card, and I got the full NCP web interface as expected, and everything, including the SATA devices, appears to be working.

So perhaps whatever was causing the problem in the RockPro64 for NCP has since been fixed in the latest Armbian? The only reason I question that is because it looked like the “latest” RockPro64 Armbian Stretch image was generated in February, which would have been before the March NCP image was created, so I would assume they’d be using the same thing under the hood? I can do some more testing of whatever would be helpful to get the NCP image for the RockPro64 working with the SATA expansion card “out of the box”, rather than having to go the Armbian Image + Install script route. Let me know, thanks!

2 Likes

We’ll create a new release soon based on the latest Armbian so that should fix the issue.

Thanks for the heads up`

1 Like

@nachoparker, That’s great news! I have not had a chance to get back to my RockPro64 since I last tried it. @joshuawhitehead’s post is EXACTLY what I’ve been seeing. Sounds like the Armbian update will fix my issues.

Thanks again for your work on NextCloudPI!

1 Like

HI @joshuawhitehead, Any chance you could point me towards the NCP install script you mentioned? I’ve been trying to get setup on a Rockpro64 with the NAS case, and experienced the same issue that folks here have been discussing. Until the update is released, I’d be interested in trying your workaround. Unfortunately I’m SUPER new to this stuff (first time working with a single board computer or Linux :confused:) I think I know where to find the Armbian image and can probably get that flashed and booted, but I wasn’t sure where to go from there based on your description.

Thanks so much!