NCP "no referrer" warning in NC 14.0.4

Hello, I have successfully installed NCP on a Pi 3b +. The installation went very smooth.

Afterwards I did an update of the system through “ncp-update” over SSH and lastly updated NC with
the NC-webupdater. Unfortunately after the update I get a “no referrer” warning message at the settings menu
in Nextcloud.

I saw an entry on Github after which the problem seems to be solved with an update to version v0.67.1.
The .htacces file do have an entry about “no referrer” in it, but it shows the warning anyways.
Did I accidently messed up something?

Thanks in advance

This is the case if the referrer header is set doubled within the webserver config. With the latest Nextcloud update it was added to the .htacces and I guess your webserver config has this set as well somewhere. Simply remove it from there and the warning should disappear.

Thanks for the response.
As indicated in the subject I’m using NCP on the pi. Should I take out the line
in the .htacces file or in the webserver config file?

As the system has its own updating mechanism I don’t want to mess things up.

Take it out in the webserver config.

I guess @nachoparker will fix it soon, since this header in .htaccess is quite new. Removing the line manually from apache config should definitely not break any update mechanism :wink:.

yes, this was fixed last weekend. You might have to restart apache2/reboot to see the warning go away

1 Like

Hi, that was the first thing I tried. Did not help unfortunately.

Did for me, what version of ncp are u on? 0.67.2 here…

Indeed there is an update to v067.4 at the time I am writing. Solved the problem completely. Thank you for the help