NCP MariaDB down after upgrade

Hi there. First of all, please excuse my english. I’m much better in reading and understandig than in writing english. :slight_smile:

I ran into some problems after upgrading NCP today: I cant acces my Nextcloud anymore. The NextCloudPi Panel tells me in red writing
Nextcloud check error
MariaDB service down

I was stupid enough to not permorm a backup :frowning:

How can I fix this?

output of sudo ncp-report please?

Edit: Post deleted. See my last post here :slight_smile:

your database is up… what error are you seeing? please, visit the FAQ section of the wiki

Yes, DB seems to be up again. But when I open Nextcloud I get
“Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.”

You didn’t include the nextcloud logs, please do

Deleted: I found some workaround to recover my data. So I simply installed NCP from scratch and imported old data.
Thank for your help, nachoparker. Your work is apreciated.

I just updated my NCP-x86 docker container (docker-compose pull and a docker-compose up -d), and from what I can tell, my nextcloud instance is having trouble reaching MariaDB as well.

If this isn’t the right place to bring this up I’ll gladly open a new topic.

Here’s my ncp-report:

One thing that stick out to me is that the DB datadir is now /data-ro/database instead of /data/database as it once was? I certainly didn’t change that, seems to have been a recent change in the source.

I have backups that run nightly, so I tried restoring from a recent one, coupled with a brand new docker container, which suffered from the same issue.

Thanks in advance for any help.

Try restoring your backup in an empty volume

I actually just finished doing that, no change =/

does it work before restoring?

I don’t understand the question.

A newly spun-up container (and volume) seems to work, but I can’t seem to get it working with my existing ncdata volume at all.

Doing a show tables on the nextcloud DB shows that it has none, though the files for the tables are definitely on the filesystem.

I’ve solved it, at least on my own machine. Solution was fourfold, all done within the nextcloudpi container:

  1. mv /data/database/nextcloud/* /data-ro/database/nextcloud/
  2. rm /data-ro/database/{idbdata1,idb_logfile0,idb_logfile1}
  3. mv /data/database/{idbdata1,idb_logfile0,idb_logfile1} /data-ro/database/
  4. chmod mysql:mysql /data/database/{idbdata1,idb_logfile0,idb_logfile1,nextcloud/*}

Followed that with a restart of mysql, and the database was now working again.

I also had to tell Apache where to find php-fpm7.2, as it seems to be configured for php-fpm7.0.

1 Like