NCP doesn´t startup on first boot


I´m trying to set up a server with ncp, but when I try to boot it for the first time i get this error message and the raspberry doesn´t connect to my router

and if i try to run raspi_config or rc_gui the raspberry freezes or it shows this error

and I don´t know how to fix the problem.

I reinstalled ncp multiple times and redownloaded the .img file multiple times but I get the same error.
Could it be that the error occur because I use a RaspberryPi 2? I´ve only seen tutorials with the RasPi 3 but the website says it supports RasPi 2 & 3.

Thanks for any help


The same method and using same sdcard?, or different methodes?, different sdcards ?
Being precise about things makes it easy to help!
Which image exactly? Provide a link to it please, so no mistake possible!
Next is methode, your OS type and software used to download and to burn;
Did you use torrent or download directly, if so did you check md5sum?
Tried changing power supply and or cables yet( 90+% problems come from these)? And using a new/other sd-card?
What sdcard are you using?, your output suggests, it is failing.

First of all, thanks for your response.

This is where I downloaded the image.

I used both and checked md5sum (it was correct).

I don´t think that is a problem, because I have another server running on this pi since a few years and I didn´t change anything except the sdcard to run ncp. (The other server runs without any problem). But I can try that.

I downloaded the image directly via my browser and via µtorrent. To burn the image I used BalenaEtcher. Right now I´m trying it with win32DiskImager.

I´m using a SanDisk 16GB SDHC card.

unfortunately I don´t have other sdcards to try. If i don´t find another problem I´ll probably need to get a new one.

Do you want to know something else

I´ve now tried to change the power supply and cable and using another sdcard, but I still get the excact same error.
I believe this image somehow doesn´t work with the RaspberryPi 2 although it says on the website that this generation is supported.
I maybe can try this image with a RaspberryPi 3 soon, if it works I need to use the newer model… and mybe the website or the image should then be updated.

I have decided, as from last weekend, to start advising against buying rpi’s to run NC.
I’ve just wasted part of my weekend trying to test ncp-dist-upgrade on a rpi3b, exchanging sdcards, powersources, ending up with dead brick that does no longer responds to keyboard.
Read this
I have learn a lot from playing with rpi’s, and am grateful for it’s existence. But please do not buy one for the purpose of running NCP only.
For learning and having fun; perfect!
For running production services; RIP my rpi
Check some alternatives at