NCP docker install issues

Hello friends,
I’m in the process of migrating my NCP instance from Raspberry Pi 4 to a new Intel based UnRAID server.
I’ve installed the NCP docker app from the UnRAID community apps and was able to log into the NCP dashboard and to the NC dashboard.
I uploaded my files and photos and things seemed to work ok using firefox on desktop MacOS.
However, now I’m seeing two issues:

  1. when I’m applying settings changes in the NCP dashboard I’m seeing an invalid origin message. (screenshot:

  2. When I initially setup NC on the new UnRAID saerver, I installed two TOTP NC apps: Two-Factor Authentication via Nextcloud notification and the Two-Factor TOTP Provider.
    Since I had both installed, after entering my username and password, the NC login page would ask me which TOTP option I would like to use. This worked as it should.
    I then decided to just work with the Two-Factor TOTP Provider app, and so I deleted the Two-Factor Authentication via Nextcloud notification app.
    However, even though I disabled and removed the Two-Factor Authentication via Nextcloud notification app, I’m still seeing the message to choose a particular TOTP solution with a message saying:

Two-factor authentication
Enhanced security is enabled for your account. Choose a second factor for authentication:
**Could not load at least one of your enabled two-factor auth methods. Please contact your admin.**

I then have an option to choose TOTP (Authenticator app) or use an TOTP backup password.
Is there a way to have the initial login page immediatly load the TOTP authenticator app provider after entering the username and password? That’s how it works on my Pi.

  1. from time to time, when I open Nextcloud on my desktop browser I’m seeing the following error messages. (screenshot:

  2. I now tried to completely disable TOTP, and as such the backup codes section in settings/security is now gone. Nevertheless, when I try to log in, the web interface still asks me to enter a Backup code. But non of the backup codes I previously had works, because I removed the TOTP provider app. Which means I can’t log in.

Hope someone can help.

Edit 1:
Added screenshots and the third issue.
Edit 2:
Added point 4.