NCP docker breaks on restart


I’ve got the x86 NCP docker set up and working well, but it breaks every time the container (or docker as a whole) restarts; the NCP info panel is accessible but shows “error” for “Nextcloud check”, and Nextcloud itself is inaccessible (port 443 goes a blank page). I tried with restart policy “no” and “unless-stopped”: same result for both.
Here’s (partial) output of ncp-report:

Thanks in advance!

Seems to be the same as my last problem. Maybe you could give this a try. But after I fixed my container, I never tried again to restart the container, docker service or the host itself.

what are the steps to reproduce? I can stop and start the container, and also stop, remove and run again without problems

Steps to reproduce:

-Installed NCP x86 docker (10-02 build) using unRAID GUI, output command is
docker run -d --name='NCP' --net='bridge' --privileged=true -e TZ="America/New_York" -e HOST_OS="Unraid" -p 'xxxx:80/tcp' -p 'xxxx:443/tcp' -p '4443:4443/tcp' -v $NCDATA':/data':'rw' --restart=unless-stopped 'ownyourbits/nextcloudpi-x86' $DOMAIN

-Go to Nextcloud (using bridged port pointing to container’s 443) and click activate, run through wizard.
-At this point Nextcloud is accessible and working as expected
-Manually reboot the container (or docker, or the host server)
-Nextcloud is now unaccessible, as detailed in the original post.

Loading a backup using nc-restore OR fixing the mysql permissions like piamuc suggested in his link (thanks!) fixes the issue, but in both cases the problem reappears again on a restart.

Thank you. Let me try to reproduce. It would be nice to have the docker logs (docker logs nextcloudpi) as well.

no luck, please give me a sequence of commands to reproduce

might be related to this