Ncp-auto-scan does not execute

Hey there. I recognized after adding files via SMB that ncp-auto-scan does not work. How can I figure out which time the task run last time? But I’m already sure it does not work because I waited more than two days with this active config and no files appeared. After I ran ncp-scan manually with the same config the files instantly showed up:

I’m using NCP v1.31.0 and NextCloud 19.0.4. Everything is running in a Docker container.

Have you tried with

I am actually not 100% sure about how this works?
Smb files are external, so will have to be included in scan for them to show up.
Opening or selecting the folder in web interface should also trigger a scan afaik.
Might show as pending if still in progress, depends how much data.

Hey I think you got me wrong. I haven’t tried this but as I understand the docs:

Set NONEXTERNAL to no (to not ignore external files).

The way I do it is that I add files/folders to the root folder of my Nextcloud user so actually it should be scanned. I think that is more of a cron problem. Because as I said as soon as I scanned the same path manually the files where there. And the scan only needs something between 1-2 min.

It’s not an external folder! I copy it into the real Nextcloud user folder. I know what you mean. I got one external folder with my downloads and this one scans if I open it in the web interface that is true and works fine.

Then, maybe check if cron is up and running with

sudo systemctl status cron.service

Nope. Looks good for me:

I set the value now to 20 and it really scans every 20 minutes. Is there a problem maybe with numbers greater than 2 digits?