NCP Activation fails


I installed the raspbian image with nextcloud from ownyourbits on my raspberry Pi. It works all until I enter with the IP of my raspi with the WebUI. The page of NextCloudPii appears with the passwords, but clicking on activate there appears that nextcloudpi is not initialized yet. I don’t know what to do but hoping you can help me.

What model rpi? (only armv7 is supported by ncp)
Which image and method did you use?
Do you have keyboard and screen attached to your rpi?
If so please share output content of ncp-log and ncp-report, if need further assistance.

Also check power source and cable, to initialize is a bit of a strain for cpu, ram, and power source.

Okay, thank you for your answer.
I use Raspberry Pi 3, Model B, 1GB RAM.
The image I used: NextCloudPi_RPi_03-04-19.tar.bz2
I flased it with balenaEtcher to my 64 GB Samsung Evo microSD Card.
I use the original cable and adapter of Raspberry. Should I try another cable?
I used keyboard, monitor and mouse the first time, but after only via PuTTY.

I found the specifications of my model, and it seems that the raspberry 3 B has the armv8. So is that the reason for the problems?
But the only raspberry with armv7 is the raspberry pi 2 B, so with all the other raspberries you cannot use ncp?

RPI3B+ should work fine
I have one that is armv7
Sorry to report; There has been a problem with that image, so suggest you wait till end of the day or tomorrow and try again with the new one that is being made presently.

In terminal wait for init done in ncp.log , after activating, with:

sudo tail -f /var/log/ncp.log

To exit after seeing init done, use


Okay, thank you very much for your help.
So tomorrow I will do ncp-init again and than it should work?
Or shall I install a complete new image?

That is worth trying also. 9 out of 10 problems start with bad power supply or cable.

You can try updating ncp with

sudo ncp-update

before running initialization again.
And checking ncp.log as mentioned above.

Okay, I tried with another cable yet, no change. ncp-update I did already, no change.
And I use the RPI3B, not the B+.
Thank you very much, I will answer after trying the new image tomorrow.

Try with other power source also!?

Yes. The same result.

Thank you Oliver for your help! I flashed the new ncp-image, had t repeat it a few times, but then it worked. I am very happy!