NCBox NC web interface connection refused

My NC snap updated itself to 10.1. I don’t see any other recent changes as I haven’t touched the box and in the last few days it’s decided to refuse connection.

ubuntu@ubuntu-standard:~$ sudo journalctl -r -u snap.nextcloud.apache.service
-- No entries --

Snap list:

Name         Version      Rev  Developer  Notes
nextcloud    10.0.1snap2  136  nextcloud  -
snapweb      0.21.2       25   canonical  -
ubuntu-core  16.04.1      424  canonical  -

Other snap commands:

ubuntu@ubuntu-standard:~$ sudo snap refresh nextcloud
error: cannot refresh "nextcloud": snap "nextcloud" has no updates available
ubuntu@ubuntu-standard:~$ sudo snap run nextcloud
error: cannot find app "nextcloud" in "nextcloud"
ubuntu@ubuntu-standard:~$ sudo snap enable nextcloud
error: cannot enable "nextcloud": snap "nextcloud" already enabled
ubuntu@ubuntu-standard:~$ sudo snap install nextcloud
error: cannot install "nextcloud": snap "nextcloud" already installed

Next idea: remove and reinstall. Any other advice before I do?

@oparoz can you help?

Have you tried both HTTP & HTTPS?

I hadn’t tried HTTP because I’d set it to HTTPS.

But that works (from a different PC since it insists on switching to HTTPS on the local machine).

So I need to re-enable HTTPS for some reason…

Yes. There was a bug in the cert generation routine which made it so that a link to the certificate would be broken after a few upgrades. It should be fixed in the latest snap.

1 Like