NC12 upgrade and integrity check error (direct menu)

Nextcloud version : 12
Operating system and version : Debian 8
Apache or nginx version : Apache2
PHP version : 5.6.30
Is this the first time you’ve seen this error?: Yes

Upgrading from to 12.0.0 using the web upgrade tool. Everything works fine after the upgrade to 12.0.0.

In the admin panel there is a code integrity check error. Looking at details it turns out the "Direct Menu’ app is responsible. I disable and remove it completely. Logout/Login and the error is still there. Looking in the directory I see the app files are still available in


Should I manually delete this folder in the backup?

Hm… that doesn’t make sense to me. They shouldn’t be doing an integrity check in the backup folder, because that doesn’t apply to the current configuration. So on the integrity check screen, they specifically said the error was with that backup directory? Or that’s just what you found while doing a search on the filesystem?

Yes, I thought that was odd as well. I did a fresh login and a ‘rescan’ from the error message popup and still get:

- direct_menu
		- OC\IntegrityCheck\Exceptions\InvalidSignatureException
		- Certificate is not valid.

Raw output
    [direct_menu] => Array
            [EXCEPTION] => Array
                    [class] => OC\IntegrityCheck\Exceptions\InvalidSignatureException
                    [message] => Certificate is not valid.



Here are the only instances of the files…

What does your current apps directory look like (not in the data directory, just in the application directory)? Does it contain a direct_menu directory? If it does, that’s what you should manually remove.

Well, Direct Menu is not supported on NC 12 anymore anyway because of the new app bar at the top. NC 12 has this feature in its core now and this app has basically gotten redundant.

@alfred Indeed. That’s why we should get rid of it. It must still be in there in the application web root somewhere (but I thought the integrity check gave you the exact path to the problem file).

I restarted Apache and flushed the cache. Problem solved without removing anything from the updater directories.
I should have done a little bit more documented testing to help with any potential bug squashing, at least NC12 humming a long like a well oiled engine again.