NC12 + Collabora Docker container == gray screen now

I was running NC11 for some time and upgraded to 12 and now Collabora CODE is borked. All I get now are gray screens where the document should be.

The exact error I get in Chrome is:
WebSocket connection to TOKEN FILE failed: Error during WebSocket handshake: Unexpected response code: 404
initialize @ bundle.js:760

In firefox I get:
Firefox can’t establish a connection to the server at wss://TOKEN FILE

So I presume I now have a configuration error of some sort. Any tips on where to look? I read thru other posts and am kinda lost as where my issue could be.

Specifics:
Running on Amazon Lightsail with the Amazon Linux
Have NC and Collabora on same instance.
Setup Apache and the reverse proxy
Certs thru LetsEncrypt (and a valid cert, renewed it to make sure)
Did reboot after doing some system updates to see if that could be the case.
Tried hosting the container on an alt domain, getting an internal server error, with NC’s log showing:
Client error response [url] https://DOMIAN.com/hosting/discovery [status code] 404 [reason phrase] Not Found

Same host docker logs output shows:
[ websrv_poll ] WRN WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:365

Remote host docker logs output shows nothing

Thanks for any help!
Andrew.

Same problem here!

1 Like

Did you see an screen like this?

Regards!

Precisely.

I have this kind of things when i update my collabora server.

Go into admin parameters -> collabora online and re enter the address of the server, validate and try again.

For me it works

In the Collabora admin I get this:

Go into admin parameters -> collabora online and re enter the address of the server, validate and try again.

Not works for me.

I meant in the admin panel of nextcloud section collabora online

I meant in the admin panel of nextcloud section collabora online

Yes, I know.

I add a different screen to show my connection problem.

Unfortunately this does not work, nor did a few months ago when I ran into this issue.

I even exported my data and respun a new vps, and still no dice.

Thanks though.

So :
1- reboot your collabora container,
2- wait 10 seconds
3- with the docker log command view in realtime the collaboralog, in the same time open a file on nextcloud who will open collabora.

The comland is docker log container_id
Or docker logs container_id

With the error code you can troubleshoot more easyly your problem.
Do us a copy/paste of them please.

wsd-00027-00035 [ websrv_poll ] ERR  Socket #20 SSL BIO error: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request (errno: Success)| ./net/SslSocket.hpp:273
wsd-00027-00035 [ websrv_poll ] ERR  Error while handling poll for socket #20 in websrv_poll: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request| ./net/Socket.hpp:474

Thanks for your help!

Two things for me, i hope someone else can help you more :
1 - there is no SSL service for your Collabora server, i always use one but it’s not making the host working down
2- You don’t have several warnings when you try to open a document,
for my part i get some WRN : missing this module etc…
when i got trouble with collabora i got some : WRN (in red) with something like bad SSL Cert or bad communication…

You don’t have this kind of things, except : WOPI HOST DID NOT PASS OPTIONAL access_token_ttl

How do you work with your collabora server, is it on the same server than your nextcloud ? do you use a reverse proxy for getting access to it… can you give us more of your configuration ?

Yes, sure!

My NC server is my own PC, running in localhost/IP.

I’m using a Docker image with Collabora, running in http://IP:9980, following this tutorial by @Mark https://www.marksei.com/how-to-integrate-collabora-online-in-nextcloud/. I run this code to disable SSL option )modifiying loolwsd.xml:

docker exec -it collabora_nextcloud /bin/bash -c "apt-get -y update && apt-get -y install xmlstarlet && xmlstarlet ed --inplace -u \"/config/ssl/enable\" -v false /etc/loolwsd/loolwsd.xml && xmlstarlet ed --inplace -u \"/config/ssl/termination\" -v false /etc/loolwsd/loolwsd.xml"

I’m using Apache, and no reverse proxy.

Solved, you can mark it as solved.

The problem was that the server was inside a lan with a proxy.

EDIT : Sorry i thought it was the topic of @alexis.rosano

1 Like

Hi Friends,

Please use the collabora url with port number if you define a particular port for collabora and nextcloud configuration file.
E.g- https://www.example.com:7008 and save