NC12 Authentication issue with Cardav, Caldav and Sogo connector

Thanks a lot! We definitely appreciate your support! :wink:


Thanks a lot the second part works for me as well.

All my attachments are working again (Thunderbird (Ligntning & Sogo), caldav -sync & carddav-sync)

While I was checking some other devices that are attached to my cloud I noticed some strange behaviour.

I own two Sony Android devices and on both carddav and caldav were not working.

A google Nexus device had the same problems,

But on three Samsung Android devices there was at least carddav working caldav not. Could not figure out why.

Now with the patch everything is back to normal.

Hope for a solution for 12.0.1.

Thanks a lot for all the effort and good work.

Issue temporary solved:

Open issue =>

Just to add another person whose calendar is busted. A fix before the next release would be really appreciated! I tried this with Lightning, California, and Evolution on my Ubuntu machine. No joy.

I’m using Evolution on Ubuntu 16.04 and getting the

Data source ‘Ian Calendar’ does not support OAuth 2.0 authentication

error with my Calendars, but not my Contacts. I would have expected that both being webdav based they should be exhibiting the same error.
All seems to be well with my CalDAV-Sync and CardDAV-Sync apps on my Android phone.

I can confirm this issue with NC 12.0.0.

Hi Folks,
I think the WEB-interface have a similar problem with the authentication.

Please look into:

The fix in this thread has got CalDav-Sync on Android working again for me too. After the upgrade it was prompting for my password.

The FIXME described above in those two files worked fine for me but I had to activate all NC calendars in Thunderbird one by one to have them displayed in Thunderbird.

Hi @nickvergessen,

thanks for your solution. Your solution worked perfect! I couldn’t add or reconnect within Thunderbird to my Calendars, because the System wouldn’t ask for Credentials. So after I implemented your Hack, it worked imediately.
Thanks again!


1 Like

Hi @nickvergessen

Update: it seems like it’s working atm, maybe because of caching or therelike the carddav sync didn’t respond to the quick fix immediately

Same problem with me. NC12 Authentication issue with Cardav, Caldav and Sogo connector worked as far as caldav sync is concerned.

Nevertheless I still cannot synchronize contacts using carddav. When starting a synchronization the synch job just will never finish. I had the same behavior with caldav before I used your mentionnen quick fixes.
I’m using the CardDav-Sync and CalDav-Sync apps on Android.

Same same - not different…

Ubuntu / Evolution
On my notebook I am working with Ubuntu and Evolution. Since migration from oc9 to nc12 synchronization of calendar and contacts is not possible.

Android / FolderSync
On my Android smartphone I have installed FolderSync. Seems that I have here the same authentification problem.

Hi all,

I am watching this thread because I have not yet upgraded to v12 as I absolutely cannot break cardDAV and calDAV support. If v12.0.1 fixes this, can one of you let us know?


We’re aiming to include the following patch in 12.0.1 which should increase compatibility again.

It should be noted however, that this is an issue and bug in the DAV clients and not in Nextcloud itself.


thanks a lot @LukasReschke

I updated BearerAuth.php in accordance to your pull request and removed the fix from @nickvergessen. I can confirm that everything still works as it did before. :thumbsup:

1 Like


if that is a bug in the dav-clients can you tell how and what can I send the developers, that they can fix that in most short time?

Thanks to @LukasReschke. And thanks to @MeCias for confirmation.

I updated my installation to use the daily build channel. When is the patch expected to show up?

Hi There,

Added proposed patch and Evolution working again.

Have you tried CardBook instead of Sogo Connector?

Hi all

I figured the exact same problem. Originally installed NC 12.0.0, then updated to NC 12.0.1, but was not able to connect to the CARDdav service with the URL mentioned in app contacts/settings, which is:

Since I could successfully connect to my CALdav service, which shows a slightly different URL setup like this:
I tried that URL with my CARDdav service - and guess what? It works :slight_smile:

This should be the way to go:

  1. Create an app password
  2. Configure your carddav client to using a URL like the following:
  3. Use the username/password you setup in step 1.
  4. You should be good to go

And since user @cbrace asked for an info if 12.0.1 has a working caldav and carddav service:
At my site, with the “fix” mentioned above, both services successfully work.

Has the patch made it into 12.0.1? I updated but Thunderbird/SOGO is still asking for login/password at every startup.