NC virtual machine backup slow (VeeAM)

I am running Nextcloud (v19.0.0) on an ESX 7.0 server as a virtual machine. The ESX machine uses a Synology DS3617xs with 8x1,92TB SSD as shared storage connected by ISCSI (10Gbit). So the VMs are lightning fast :slight_smile:

My question is does somebody know why when i use VeeAM (v10) for a backup of the Nextcloud VM the processing speed is around 100MB/s.

Which is weird because other VM backups, like Exchange, Domain Controllers, Unifi controller, PFsense and vCenter speed up to at least 600MB/s average. So not a temporary spike.

The backups are done on a RAID5 3x8TB also on the Synology (so also ISCSI connected)

Could somebody explain why the Nextcloud VM backup is so slow? It doesn’t make a difference if i use incremental or reverse incremental.

Are you saying your NC data folder is ~15TB?

Did you snapshot the NC virtual machine before the first backup?

If so, delete the snapshot (all of them), do the FIRST backup and then snapshot it…


No my Nextcloud VM in total is 2.5TB. Sorry if i gave the impression it was 15TB.

But this is not the issue, the problem is that it is very slow regardless of how much data. Or am i missing a correlation between the two?

I don’t use snapshot. I just backup the virtual machine.

You do…
If there is a snapshot of the VM, Veeam will read every byte of the NC VM regardless how much data is on it, even if none… And will do it very slow (in my case 1TB about 3 hours)…

Remove snapshots - backup will be done in 10 minutes…


Press Delete All Snapshots BEFORE first Veeam backup…


Thanks for explaining, but there are no snapshots. Well at the moment there is one, but that is clearly the one used by the current running backup (it says so in the description) I will check but i am almost a 100% sure this snapshot will be gone tomorrow.

Did you do just one backup or more? Is it slow every time?

Did you do thin- or thick-provisioning of the 2.5TB data partition?

Do you run vCenter?
If so, did you add the backup job in Veeam using vCenter or ESXi host it runs on?
Did you add the NC backup job, delete it, and add again?
All those things could matter…

I don’t have a good explanation why…
But just getting rid of vSphere snapshots solves these issues for me every time…

There is also some registry key to make Veeam ignore presence of snapshots…

I use vSAN on a cluster (all-flash 72TB) and QNAP (224TB HDD) as repository.
QNAP is connected over NFS, but I had some iSCSI storage boxes until last year…

Maybe it’s something Synology-specific? Never worked with them…


I use thin provisioning.
Yes i use vCenter.
I will try to delete the backup job and recreate it.

Something Synology-specific… could be of course but that wouldn’t explain why all my other VM’s are being backupped fast. right?

I run Veeam myself, I get around 500 MB/s on a 10 GB NIC with peaks to about 900 MB/s. The peaks are when the data is already there, and 500 MB/s are when it’s pushing new data.

Maybe it doesn’t help much, but at least that’s my experience.