NC update stuck on step 6 from 18.0.10 to : beginner needs help

Problem when updating through web updater.
Stuck on step6 : Step 6 is currently in process. Please reload this page later.

What should I do ?

what’s the exact error-message?

anyways: try downloading the updater file manually and do the update manually like suggested on the manual

the exact error-message :
nextcloud.tld/updater/index gives “Step 6 is currently in process. Please reload this page later.

Don’t you think that before doing update manually, I shoudl get out of update process ?

hard to believe that this is the whole message, really.

well since you deny giving out more and detailed info about the problematic systemmm i only can suggest generic things as well…

search the forum on how to reset updates… and check the manual on how to update manually.

I can only give what I have. :wink: See by yourself hereafter on the picture
I can also give the content of the file updater.log :slight_smile:
Does it help you to help me ?

2020-10-16T22:01:26+0200 MknRFjlxrk [info] Step 4 is in state “end”.
2020-10-16T22:01:26+0200 MknRFjlxrk [info] POST request for step “5”
2020-10-16T22:01:26+0200 MknRFjlxrk [info] startStep(“5”)
2020-10-16T22:01:26+0200 MknRFjlxrk [info] verifyIntegrity()
2020-10-16T22:01:26+0200 MknRFjlxrk [info] getUpdateServerResponse()
2020-10-16T22:01:26+0200 MknRFjlxrk [info] updaterServer:
2020-10-16T22:01:26+0200 MknRFjlxrk [info] releaseChannel: stable
2020-10-16T22:01:26+0200 MknRFjlxrk [info] internal version:
2020-10-16T22:01:26+0200 MknRFjlxrk [info] updateURL:
2020-10-16T22:01:27+0200 MknRFjlxrk [info] getUpdateServerResponse response: Array
[version] =>
[versionstring] => Nextcloud 19.0.4
[url] =>
[web] =>
[changes] =>
[autoupdater] => 1
[eol] => 0
[signature] => rg3l/a/fYyVG36nM1Vraz+0tafxvHovk+KzkZ+9k2v3/EGg7zumk3e1vX84gA9Au

2020-10-16T22:01:27+0200 MknRFjlxrk [info] storage location: … nextcloud/data/updater-ocq9unaqmxbd/downloads/
2020-10-16T22:01:27+0200 MknRFjlxrk [info] end of verifyIntegrity()
2020-10-16T22:01:27+0200 MknRFjlxrk [info] endStep(“5”)
2020-10-16T22:01:27+0200 3vHxwXecUD [info] request to updater
2020-10-16T22:01:27+0200 3vHxwXecUD [info] currentStep()
2020-10-16T22:01:27+0200 3vHxwXecUD [info] Step 5 is in state “end”.
2020-10-16T22:01:27+0200 3vHxwXecUD [info] POST request for step “6”
2020-10-16T22:01:27+0200 3vHxwXecUD [info] startStep(“6”)
2020-10-16T22:01:27+0200 3vHxwXecUD [info] extractDownload()
2020-10-16T22:01:27+0200 3vHxwXecUD [info] storage location: … nextcloud//data/updater-ocq9unaqmxbd/downloads/
2020-10-16T22:02:15+0200 Delddrsfrt [info] request to updater
2020-10-16T22:02:15+0200 Delddrsfrt [info] currentStep()
2020-10-16T22:02:15+0200 Delddrsfrt [info] Step 6 is in state “start”.
2020-10-16T22:02:16+0200 zKc03JjUhs [info] request to updater
2020-10-16T22:02:16+0200 zKc03JjUhs [info] currentStep()
2020-10-16T22:02:16+0200 zKc03JjUhs [info] Step 6 is in state “start”.
2020-10-16T22:02:17+0200 G7hJW3D4vg [info] request to updater
2020-10-16T22:02:17+0200 G7hJW3D4vg [info] currentStep()


If it is still stuck there, you could either ssh in or remove the .step file inside the data/updater-xxxx folder. If you want to be on the safe side, do a backup of the file first, but usually thats not necessary. After that retry.
I had a similar issue too and it was due a downloading/unpacking problem.

Thanks, still stuck in step 6 . I tried to remove “.step” file but no change.
Web updater is currently not reliable, and I don’t feel like manually upgrading.
I think I will withdraw Nexcloud from my server because it’s too difficult to maintain for me.
Maybe later again if more stable.


Seems this exact issue has been answered on the forum before. Try this from the terminal on your server…

sudo -u www-data php /path/to/nextcloud/occ maintenance:repair

See full instructions here on why this command is relevant.

If that doesn’t work, might be worth trying these instructions on solving being stuck at step 6.

Maintenance mode off, then go to the directory where you store your data and find the updater-oc*** and appdata-oc*** directories and remove those. Finally, run the updater from the command line:

sudo -u www php /path/to/nextcloud/updater/updater.phar

1 Like

Hi just,
I’m sorry but I don’t understand "try this from the terminal on your server
sudo -u www-data php /path/to/nextcloud/occ maintenance:repair ".
My Nextcloud is installed on a mutual server from OVH.

How to “send” this command in that case ? with PuTTY ? (don’t know yet how to connect , but could find)

Maybe OVH can help you out. Sounds like you did not install this yourself, right?

Hi All, This is my first post and I’ve only been using NC for about 6 months so please be gentle.

I tried to update NC from 19.0.3 to 19.0.4 using the UI and it seems to have got stuck at step 6. I have tried to follow a number of different suggestions found here on the forums but nothing seems to work fully. I can manage to reset the update back to the start [not the admin page but the first update page step 1] but it just gets stuck at the same point again.

There are a number of suggestions which relate to running the commands below [with the correct paths];

sudo -u www-data php /path/to/nextcloud/occ maintenance:repair
sudo -u www php /path/to/nextcloud/updater/updater.phar

When I do this I get the following outputs respectively;

sudo -u abc -s /bin/bash -c “php7 /config/www/nextcloud/occ $"
sudo -u abc -s /bin/bash -c "php7 /config/www/nextcloud/updater/updater.phar $

But then nothing just back to the prompt. When I go back to the UI and refresh the page it either still states the update is running, the connection gets refused, or I get sent to the page which gives me instructions to update the secret key [which I have done].

My main question is are the outputs from the PHP scripts doing anything or is the problem that they aren’t and I need to fix that to be able to make them effective.

I am running NC as a docker on Unraid 6.8.3.

Thanks in advance for any help/guidance you can provide.