NC Update 11.0.5 to 12.0.4 via webupdater > Extracting " Cant handle ZIP file. Error code is: 4"

nc11
nc12
update_problems

#1

i just want to update my nc 11.0.5 to 12.0.4 using the online updater it hangs in point extracting " Cant handle ZIP file. Error code is: 4" couldnt find anything in the internet.
does anyone know something about that?

can’t find any nc12 zip on the system at all, so i kinda think downloading didn’t work.

im about to just do the update via comandline now.


#2

If you are on debian/ubuntu
Can you verify that you have zip/unzip installed :
apt install zip


#3

well its debian an at least unzip is installed and in standardpath


#4

I did the update manually now. - realizing that the manual und that has pretty maany flaws which will make inexperienced users who just want to follow the guide loose all hope multiple times.

besides that after some very weirf behaviour the update seems to have worked and im on 12.0.4 now…

also intalled zip well see waht happens next time…


#5

and as well the php-zip stuff as mentioned in the requirements:
https://docs.nextcloud.com/server/12/admin_manual/installation/source_installation.html#prerequisites-for-manual-installation


#6

yes i mean the manual installation a) worked
b) the webupdater worked the last 2 times
c) i would expect the updater to state if zip utilities are missing right?

but also thanks for the idea :slight_smile:


#7

It should. Though I’m not sure such things are always tested. If this isn’t properly detected, don’t hesitate to file a bug report.