Nc-rsync-auto not working

Hey Folks, i have a problem with rsync. nc-rsync works fine. (rsync & ssh are already configured and working). if i enter the same data in nc-rsync-auto i get the message “Permission denied, please try again.” does anyone have any clues for me? Thanks in advance :slight_smile:

Have you set up rsa pub key, so the user can login without password?
That might be required…
A bit of wild guess with only

to go on…

Could you share output of sudo ncp-report ?

1 Like

Hey Oliver, thanks for your reply.

Yes, i set the rsa-pub key. The Login is working, a single rsync-task vis “nc-rsync” works fine. I want to automate the task, i assume “nc-rsync-auto” is the right job to do. I’m using the same credential’s for this task.

I parsed through the ncp-report, but could’nt find a hint. Where do you want me to share the Informations? (it contains some Informations which i don’t want to share in public)


Hi dracon,
I use
ncp-report should remove all personal and sensitive data, but you can still edit and mask more if you want to, before posting a link here.

rsync can be tricky and behave different when running from cron, and you may have to let it know which user’s rsa-pub key it should use.
Adding below code at start of rsync script, executed by cron, does that,

if [ -z “$SSH_AUTH_SOCK” ]
export SSH_AUTH_SOCK=/run/user/1000/keyring/ssh

1000 being the first available user ID (on most but not all Linux systems), it’s usually me :wink: or pi on a rpi.

following the Guidelines through nextcloupi, the script “” generates the config for the cron in “/etc/cron.d/ncp-rsync-auto”. I think, you want me to add the code you provided to this File? Problem then is: the file will not be created through the failure of the ssh test in the “DESTINATION” Section of the - Script…

or do I take you completely wrong?

No, you are quite right.

Maybe it could/should be added to nc-rsync-auto.cfg as a new option ?

I’d attempt to create my own script and add a conjob myself until someone more knowledgeable finds time look in to it.

It might still be useful to have your ncp-report.

here ist the Link to the results of ncp-report

if nc-rsync works without passwords, so should the auto version.

You have to setup your SSH session to allow passwordless login and access to the destination folder for the sync user.

This is exactly the problem I have. nc-rsync works and creates a backup on the target system in the specified directory. The permissions are set - otherwise nc-rsync wouldn’t work either. I am using the same user and the same target directory.


Weird. In that case, please check the contents of /etc/cron.d/ncp-rsync-auto

…looks pretty fine:

0 3 */7 * * root /usr/local/bin/ncp-backup-auto

have you tried running this as root?

on closer inspection, the question arises:

the ncp-rsync-auto file contains an entry that triggers an ncp-backup-auto? is that so correct? if i run the /usr/local/bin/ncp-backup-auto as root, it works fine, but it creates a backup in the given target path (in this case a USB medium)

I don’t want to do that with rsync.

The goal is to run the rsync task automatically via cron. -> this is what nc-rsync-auto should do?

The contents of /etc/cron.d/ncp-rsync-auto please (rsync not backup)

the file does not exist. (and is not generated when I enable ncp-rsync-auto) Maybe this is the problem? Does the message “Permission denied” refer to the filesystem permission?

By the way: thanks for your continued support!

ah permission denied. Just upgrade to the latest NCP version, that has been fixed.

Or you can still use ncp-apps through ncp-config