Nc-restore KO from Pi2B to Pi3+ (nc13) - internal server error

Issue migrating nc13 from Pi2B to Pi3+ nextcloud box :
I first set up a nc instance (from ownyourbits) in a nextcloud box with a Pi2B and 1TB USBdrive, then bought a Pi3+ to replace the Pi2.
What I did :

  • run nc-backup on my PI2B (raspbian 8, NC 13)
  • download the image for the Pi3+ (from ownyourbits), mount the DD and set NC to work on the USBdrive => OK
  • run nc-restore to load my NC instance & data => 8h ending OK

my problem : when accessing nc in FF I get an error : “Internal Server Error.
The server encountered an internal error and was unable to complete your request. Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.”

could it be something like the database password that changed between the Pi2B img and the Pi3 img ?
what is the “server log” and where do I find it ?

I am not a “linux geek” :wink: thank you for your help (english or french) !


please share the output of sudo ncp-report

Sorry I shut down yesterday night without copying the output, which is lost now (new putty session).
I read it though, most of the messages seemed OK, except that some files had a timestamp “in the future”. but no error message as far as I understand…
where can I find the “server log” mentionned on the web page ?

sorry again I answered about NC-restore…

nothing weird in ncp-report.

what’s the output of

sudo -u www-data php /var/www/nextcloud/occ status

Thanks for your help. Out of office now I will answer you by april 30.

$ sudo -u www-data php /var/www/nextcloud/occ status

  • installed: true
  • version:
  • versionstring: 13.0.1
  • edition:

everything seems fine ( did you delete your ncp-report? I don’t see it )

here is a new ncp-report output (link)
ncp-report 0429

everything seems fine. The one error you see is a false alarm that was corrected in v0.53.30. Update and it should go away

you still get the error? in that case, it is probably a hardware problem. Try with a better power supply and SD card.

hi, thanks for trying to help.
the server error says “more details in the server log” where is that “server log”? I presume it is the web server?
the main question is : if I have a NC running on a hardware (PI2B, 64bits, raspbian 8) and I only want to upgrade the hardware (PI3+, 64bits), how can I do ? I tried several methods : 1) change the PI board with the same SD card : would not boot… 2) set a raspbian 9 image with NC, and plug the old USBdrive on it : could not manage to mount it so that NC recognizes it ; 3) tried NC-restore without success up to now.
I will try again and imagine other ways to do it…

this is what you want. It has to boot, again: check power supply and SD card

did as you said. tried with two different powerfull power supplies and a new SD card ; boot stays stuck on the rainbow flash screen.
for now my PI2 NC works fine and fast, so I will start again from scratch with the PI3+ and go on step by step to understand how to succeed.
I’ll let you know if I succeed :slight_smile:

good luck!