NC on raspberry with synology mount


i have just installed nextcloud on my raspberry pi running raspbian. during inital setup, i had to set a specific data directory. my smb mount directory is /home/pi/nextcloud. however, i cannot use this directory. it is readable by other users and i need to change permissions to 0770. this does not work because i do not have the permission to do so (even though i am trying to change permissions as root).

there is no point storing all nc data locally on my raspberry pi. how can i automatically use external storage for sync? i have installed external storage plugin and added my smb mount. this works. however, files synced via android app or osx client are not stored in external storage.

can somebody please help me out? thanks in advance :slight_smile:

1.) do you mount the Dir during boot using fstab?
2.) why cant you use it? What are the mounting options?
3.) the permissions are dependent on the user you use for mapping. If this user has permission on r/w on the NAS, everything should work from PI-Side

Of course you cant change the chmod on th NAS files if the mounting-user has e.g. Only read

1.) i have edited the fstab file, but I believe I need to “sudo mount -a” manually before mounting actually happens.

2.) i mounted like this
//NAS /local_folder auto cifs auto,username,password,domain,nodfs 0 0
(nodfs because mounting does not seem to work without this option)

3.) i can write to the folder as user pi. changing permissions does not seem to work. the user pi does not exist on my NAS, however, I used the correct user with permissions within the fstab file.

I had this exact problem back in the day when using owncloud. It was actually the reason I stopped using it. Now I am kinda surprised that nextcloud has the same problem…