NC on Docker with Nginx

I have docker running Nginx and Nextcloud.

I have external DNS setup and everything is mostly working properly. However, it appears my NC is not fully secure via SSL.

I deployed NC using port 88 in docker

I have Nginx proxy traffic destined for:
cloud.domain.com > nc:88

I have Nginx SSL bound for the cloud.domain.com name.

Everything appears to work fine, I can access the dns name internally and externally via port 80 and 443. However, when I try to launch the mobile app and login, I get a failure message when I try to login to https://cloud.domain.com when I change to http I’m able to login but it’s not using SSL.

Further, when I share a file, it shares a http link and not https.

I’m assuming it’s because I don’t have https turned on the docker for nextcloud. I tried to run through the letsencrypt after installing the certbot:
certbot --apache -d cloud.domain.com

But I don’t get past the verification step, I’m assuming either and issue with Nginx passing the traffic or the nextcloud websevice intercepting the request.

Any guidance would be appreciated.

your docker-compose file would be helpful. if you setup your system via docker-compose.

that make no sense to me. if you run nextcloud as a docker container you put a nginx reverse proxy in front of it. and the nginx reverse proxy would normally handle the certificates.

I didn’t use a composer file. I figured out what needed to be done. SSL wasn’t enabled on the docker so I used terminal to install the dependencies, generate a cert, then modified the config file to use SSL on port 88. Now my proxy works and app/share links reference https instead of http.

Try going to https://ssllabs.com/ssltest and running their SSL test.

there is no need to enable TLS in Nextcloud container but you need to adjust some settings when running behind reverse proxy

hope you did it right. otherwise you will be surprised with the next update of your container.