Nc not finding all files in folder

hi,
I already asked in the german subforum (Maximale Dateianzahl bei externen Speichern?) but still haven’t solved this.

My nextcloud 18.0.8 installation, with MySQL db and redis if that matters, does not find all files in a certain folder. This folder is a CIFS share on my Windows server mounted with External Storage.

It only shows the first 430 files alphabetically and then just stops.
I tried to do an occ files:scan --verbose on the folder and again it just stops at 430 files after the files starting with L.
If I rename a file with a filename starting with Z to A_oldfilename it shows up and one file at the bottom drops out.
When I tried occ files:scan for the first time I had an error with file locking and redis, which I fixed by clearing redis cache. I now tried to increase maxmemory to 512mb in redis.conf, because I thought it might not fit more than 430 filenames, which did not change anything.

When I set my nextcloud up I did not have this issue, it must have come with an update or something, but I do not know exactly which one, because I rarely access this folder.

Does anybody have an idea what the problem might be or what I could check?

as mentioned in german in my other thread I found the solution here:


forcing SMB3 in /etc/samba/smb.conf by adding
client max protocol = SMB3
directly under the [global]-tag solved my problem.

1 Like