NC Felermeldungen

Mein Sever hat eine menge Fehlermeldungen Ich Brauche euere Hilfe um diese zu beheben.

Mein Setup
-Lokal
-Awow Pc mini Pc
-Ubunto Server

  • Nextcloud Version: 25
  • PHP Version: PHP 8.1.11
  • Welche Datenbank? MySql,
  • Wurden vor kurzen Server Updates gemacht? nein
  • Habt ihr die Logs angesehension, usw. von Nextcloud und von System? nein

  • Es gibt einige Warnungen zu Ihrer Systemkonfiguration.
  1. Unsicherer Seitenzugriff über HTTP. Es wird dringend empfohlen, den Server so einzurichten, dass HTTPS erforderlich ist, wie dies in den Sicherheits-Tipps :arrow_upper_right: beschrieben wird.

  2. Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/webfinger” aufzulösen. Weitere Informationen hierzu finden Sie in unserer Dokumentation :arrow_upper_right:.

  3. Sie haben Ihre E-Mail-Serverkonfiguration noch nicht festgelegt oder überprüft. Bitte gehen Sie zu den Grundeinstellungen , um sie einzustellen. Verwenden Sie anschließend die Schaltfläche “E-Mail senden” unterhalb des Formulars, um Ihre Einstellungen zu überprüfen.

4.Für Ihre Installation ist keine Standard-Telefonregion festgelegt. Dies ist erforderlich, um Telefonnummern in den Profileinstellungen ohne Ländercode überprüfen zu können. Um Nummern ohne Ländercode zuzulassen, fügen Sie bitte “default_phone_region” mit dem entsprechenden ISO 3166-1-Code :arrow_upper_right: der gewünschten Region hinzu.

5.Bitte überprüfen Sie noch einmal die Installationsanleitungen :arrow_upper_right: und kontrollieren Sie das Protokoll auf mögliche Fehler oder Warnungen.

(upload://aRsyNIMXNuWmQHanDZiL4xeeZE7.png)
Überprüfen Sie die Sicherheit Ihrer Nextcloud mit unserem Sicherheits-Scan :arrow_upper_right:.

{“reqId”:“zDWmR2tmPKqVRmpNpyYa”,“level”:3,“time”:“2022-12-11T00:05:25+00:00”,“remoteAddr”:“192.168.178.100”,“user”:“Admin_99”,“app”:“richdocuments”,“method”:“GET”,“url”:“/ocs/v2.php/apps/notifications/api/v2/notifications”,“message”:“Failed to fetch the Collabora capabilities endpoint: cURL error 7: Failed to connect to 192.168.178.50 port 80 after 3075 ms: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for http://192.168.178.50/apps/richdocumentscode/proxy.php?req=/hosting/capabilities",“userAgent”:"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36”,“version”:“25.0.1.1”,“exception”:{“Exception”:“GuzzleHttp\Exception\ConnectException”,“Message”:“cURL error 7: Failed to connect to 192.168.178.50 port 80 after 3075 ms: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for http://192.168.178.50/apps/richdocumentscode/proxy.php?req=/hosting/capabilities",“Code”:0,“Trace”:[{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,“line”:158,“function”:“createRejection”,“class”:“GuzzleHttp\\Handler\\CurlFactory”,“type”:“::”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,“line”:110,“function”:“finishError”,“class”:“GuzzleHttp\\Handler\\CurlFactory”,“type”:“::”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlHandler.php”,“line”:47,“function”:“finish”,“class”:“GuzzleHttp\\Handler\\CurlFactory”,“type”:“::”},{“file”:“/var/www/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php”,“line”:113,“function”:“__invoke”,“class”:“GuzzleHttp\\Handler\\CurlHandler”,“type”:"->”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php”,“line”:35,“function”:“OC\Http\Client\{closure}”,“class”:“OC\Http\Client\DnsPinMiddleware”,“type”:“->”,“args”:[“*** sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:31,“function”:“__invoke”,“class”:“GuzzleHttp\PrepareBodyMiddleware”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/RedirectMiddleware.php”,“line”:71,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:“::”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php",“line”:63,“function”:“__invoke”,“class”:“GuzzleHttp\RedirectMiddleware”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/HandlerStack.php”,“line”:75,“function”:“GuzzleHttp\{closure}”,“class”:“GuzzleHttp\Middleware”,“type”:“::”,“args”:[" sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php",“line”:331,“function”:“__invoke”,“class”:“GuzzleHttp\HandlerStack”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php”,“line”:168,“function”:“transfer”,“class”:“GuzzleHttp\Client”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php”,“line”:187,“function”:“requestAsync”,“class”:“GuzzleHttp\Client”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Http/Client/Client.php”,“line”:218,“function”:“request”,“class”:“GuzzleHttp\Client”,“type”:“->”},{“file”:“/var/www/nextcloud/apps/richdocuments/lib/Service/CapabilitiesService.php”,“line”:132,“function”:“get”,“class”:“OC\Http\Client\Client”,“type”:“->”},{“file”:“/var/www/nextcloud/apps/richdocuments/lib/Service/CapabilitiesService.php”,“line”:74,“function”:“refetch”,“class”:“OCA\Richdocuments\Service\CapabilitiesService”,“type”:“->”},{“file”:“/var/www/nextcloud/apps/richdocuments/lib/AppInfo/Application.php”,“line”:80,“function”:“getCapabilities”,“class”:“OCA\Richdocuments\Service\CapabilitiesService”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Bootstrap/FunctionInjector.php”,“line”:67,“function”:“OCA\Richdocuments\AppInfo\{closure}”,“class”:“OCA\Richdocuments\AppInfo\Application”,“type”:“->”,“args”:[" sensitive parameters replaced ***”]},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Bootstrap/BootContext.php”,“line”:51,“function”:“injectFn”,“class”:“OC\AppFramework\Bootstrap\FunctionInjector”,“type”:“->”},{“file”:“/var/www/nextcloud/apps/richdocuments/lib/AppInfo/Application.php”,“line”:135,“function”:“injectFn”,“class”:“OC\AppFramework\Bootstrap\BootContext”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php”,“line”:190,“function”:“boot”,“class”:“OCA\Richdocuments\AppInfo\Application”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_App.php”,“line”:208,“function”:“bootApp”,“class”:“OC\AppFramework\Bootstrap\Coordinator”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/legacy/OC_App.php”,“line”:141,“function”:“loadApp”,“class”:“OC_App”,“type”:“::”},{“file”:“/var/www/nextcloud/ocs/v1.php”,“line”:57,“function”:“loadApps”,“class”:“OC_App”,“type”:“::”},{“file”:“/var/www/nextcloud/ocs/v2.php”,“line”:23,“args”:[“/var/www/nextcloud/ocs/v1.php”],“function”:“require_once”}],“File”:“/var/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php”,“Line”:210,“message”:“Failed to fetch the Collabora capabilities endpoint: cURL error 7: Failed to connect to 192.168.178.50 port 80 after 3075 ms: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for http://192.168.178.50/apps/richdocumentscode/proxy.php?req=/hosting/capabilities",“exception”:[],“CustomMessage”:"Failed to fetch the Collabora capabilities endpoint: cURL error 7: Failed to connect to 192.168.178.50 port 80 after 3075 ms: No route to host (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for http://192.168.178.50/apps/richdocumentscode/proxy.php?req=/hosting/capabilities"},“id”:"63951ef8ee495”}

Auch wenn es nach vielen Meldungen aussieht, ist es alles nicht so schlimm. Am besten wir teilen die Meldungen auf.

SSL:
Verwendest du den Server nur intern oder willst du ihn auch von extern verwenden. Grundsätzlich hat man mit SSL immer Ärger, wenn man es nur intern verwendet. Ohne SSL bekommt man diese Fehlermeldungen (ich weiß auch gar nicht, ob der Client dann läuft) und mit einem selbst signierten Zertifikat ist es auch nicht besser. Besser ist es, wenn man die Nextcloud von außen zugänglich macht und einfach wie in vielen Anleitungen Lets Encrypt verwendet. Dann aber auch nicht auf die interne IP, sondern von innen und außen auf die externe IP.

Schreib mal, was du in die Richtung so vor hast.

.well-kown
Schreib mal ob du nginx oder Apache2 verwendest. Es gibt im Internet zu den “Problemen” eigentlich genug Anleitungen. Vielleicht mal nach well-known nextcloud nginx oder well-known nextcloud apache2 suchen

Den Rest kannst du erst mal ignorieren, wenn du die Nextcloud sowieso nur intern und für dich als Datenablage verwendest.

Ich Habe
nano 000-default.conf

RewriteEngine on
RewriteRule ^/.well-known/carddav /nextcloud/remote.php/dav [R=301,L]
RewriteRule ^/.well-known/caldav /nextcloud/remote.php/dav [R=301,L]
RewriteRule ^/.well-known/webfinger /nextcloud/index.php/.well-known/webfinger [R=301,L]
RewriteRule ^/.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo [R=301,L]

<
<

Am ende Der Datei einefügt Hat aber keine wirckung

GNU nano 6.2 /etc/apache2/sites-available/000-default.conf
<VirtualHost *:80>
# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request’s Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.
#ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    #DocumentRoot !!!!!!!!!!!!!!!!!!!!!!!!!!111111

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf

vim: syntax=apache ts=4 sw=4 sts=4 sr noet

RewriteEngine on RewriteRule ^/\.well-known/carddav /nextcloud/remote.php/dav [R=301,L] RewriteRule ^/\.well-known/caldav /nextcloud/remote.php/dav [R=301,L] RewriteRule ^/\.well-known/webfinger /nextcloud/index.php/.well-known/webfinger [R=301,L] RewriteRule ^/\.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo [R=301,L]

Ist in Disen bereich ein Feler