NC - does not work anymore strange issue, looks like never installed?

Hello All, 

	i hope you are all good. 

	Today i seeking help here in this forum. 
	As our NC suddenly stopped working.
	A little bit of background: 

	We had a NC up and running for now some months without any issues. 
	Basic Infos: 

Its a dedicated system (Running as VM on Unraid Server)

Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.4 LTS
Release:	20.04
Codename:	focal

I am able to connect to the system itself and also connect via SSH. 
The First think i checked was the free disk space as i supected this could be an issue, as i never checked it. 
I supectiong a issue with the rights as i am not able to enter the www folder at all. 
	-bash: cd: www: Permission denied
Output of $df-h
	Filesystem      Size  Used Avail Use% Mounted on
	udev            2,1G     0  2,1G   0% /dev
	tmpfs           412M  1,6M  411M   1% /run
	/dev/vda2       2,2T  115G  1,9T   6% /
	tmpfs           2,1G     0  2,1G   0% /dev/shm
	tmpfs           5,3M     0  5,3M   0% /run/lock
	tmpfs           2,1G     0  2,1G   0% /sys/fs/cgroup
	/dev/loop1      132k  132k     0 100% /snap/bare/5
	/dev/loop2       59M   59M     0 100% /snap/core18/2409
	/dev/loop0       59M   59M     0 100% /snap/core18/2344
	/dev/loop4       66M   66M     0 100% /snap/core20/1518
	/dev/loop6      230M  230M     0 100% /snap/gnome-3-34-1804/77
	/dev/loop3      230M  230M     0 100% /snap/gnome-3-34-1804/72
	/dev/loop5       66M   66M     0 100% /snap/core20/1494
	/dev/loop8      244M  244M     0 100% /snap/nextcloud/31033
	/dev/loop9       54M   54M     0 100% /snap/snap-store/547
	/dev/loop7       86M   86M     0 100% /snap/gtk-common-themes/1534
	/dev/loop10     267M  267M     0 100% /snap/gnome-3-38-2004/106
	/dev/loop11      57M   57M     0 100% /snap/snap-store/558
	/dev/loop12      50M   50M     0 100% /snap/snapd/16010
	/dev/loop14      97M   97M     0 100% /snap/gtk-common-themes/1535
	/dev/loop13     421M  421M     0 100% /snap/gnome-3-38-2004/112
	/dev/loop15      47M   47M     0 100% /snap/snapd/15904
	/dev/vda1       536M  5,5M  531M   2% /boot/efi
	tmpfs           412M   37k  412M   1% /run/user/125
	tmpfs           412M  8,2k  412M   1% /run/user/1000

I am not quite sure if this is the problem or not, as the /dev/loopXX folders are all 100% used, this can not be right. 
On the other i am not sure for what those folders are there. 

I am also not sure where to start for trouble shooting as all steps i try do looks liks they are not woring, like nextcloud.occ (or $sudo nextcloud.occ)

output nextcloud.occ
	Nextcloud is not installed - only a limited number of commands are available
	Nextcloud 24.0.1

	  command [options] [arguments]

	  -h, --help            Display this help message
	  -q, --quiet           Do not output any message
	  -V, --version         Display this application version
	      --ansi            Force ANSI output
	      --no-ansi         Disable ANSI output
	  -n, --no-interaction  Do not ask any interactive question
	      --no-warnings     Skip global warnings, show command output only
	  -v|vv|vvv, --verbose  Increase the verbosity of messages: 1 for normal output, 2 for more verbose output and 3 for debug

	Available commands:
	  check                 check dependencies of the server environment
	  help                  Display help for a command
	  list                  List commands
	  status                show some status information
	  app:check-code        check code to be compliant
	  integrity:check-app   Check integrity of an app using a signature.
	  integrity:check-core  Check integrity of core code using a signature.
	  integrity:sign-app    Signs an app using a private key.
	  integrity:sign-core   Sign core using a private key.
	  l10n:createjs         Create javascript translation files for a given app
	  maintenance:install   install Nextcloud
If i chech the status: 
	§sudo nextcloud.occ status

	Nextcloud is not installed - only a limited number of commands are available
	  - installed: false
	  - version:
	  - versionstring: 24.0.1
	  - edition: 
	  - maintenance: false
	  - needsDbUpgrade: false
	  - productname: Nextcloud
	  - extendedSupport: false
Why is it no longer isntalled ? 
I am pretty confussed right now. 
I did not do an update/upgrade at all. 

When i try to run the maintenance: install comannd, i get the following message: 
	  Database <sqlite> is not supported
As i menationed before, it worked püretty well and fast for months now. 
All the updates worked fine. 

What could be the reason here ? 
How do i dive deeper to find the root cause if this issue?

I am limited to myknowledge of this but i`ll try as best as possible. 
Would be gerat fo have the NC back up and running. Also der are some files i need to have access again. 

The php8.0-fpm.log is empty…

I would start by verifying that the www folder is intact. Don’t change permissions on it. Should all be owned by your web server user typically.

This is just a guess but it sounds like maybe there could be a problem involving the Nextcloud config file. It would be in /config under the web root.