NC could not reached for new updates

The Update server could not be reached since 6 days to check for new updates

the currently version of my NC is 12.0.4 running on centos7 with MySQL Database

my server of NC have permission of Internet Connection no idea why i encountered error


1 Like

I did get this one a long time ago.
It was a DNS config error on my server so it couldn’t resolve any hostname.
As suggested by the warning, check your nextcloud logs in the administration panel.
If it’s the same error, you should see errors like ‘unable to resolve …’ or ‘hostname not found’ or ‘hostname not available’.

ok thanks you for tip
ill feedback later

until now still NC cant update
nextcloud update could notbereached

i checked log files but i dont see any DNS problem i tried ping some website using terminal of linux it works fine

does anyone how to fix this


I’m affraid without logs from both your nextcloud instance and your server, it’ll be hard to guess what’s going on.

ok i will upload the http log file and nc log

Hey guys i still getting error server could not not be reached since 17 Days cant find about DNS error my server has internet connection i can able to update the system thru terminal mode.

any ideas


i found this error on nextcloud log

Could not connect to appstore: {“Exception”:“GuzzleHttp\Exception\ConnectException”,“Message”:“cURL error 35: Cannot communicate securely with peer: no common encryption algorithm(s).”,“Code”:0,“Trace”:"#0 /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(104): GuzzleHttp\Exception

I have the same error and no DNS problem. Moreover, there is no relevant information in nextcloud.log file nor in the Logging in Nextcloud web.

Did you find something helpful ?

Best regards